How to fix the error 'u/3�', should be 'TFL3'?

Hi,

so after my first installation following the guide at https://deepspeech.readthedocs.io/en/latest/?badge=latest I tried to use it with the provided command:
deepspeech --model deepspeech-0.9.3-models.pbmm --scorer deepspeech-0.9.3-models.scorer --audio audio/2830-3980-0043.wav, but if I do that, I get an error:

Loading model from file deepspeech-0.9.3-models.pbmm
TensorFlow: v2.3.0-6-g23ad988
DeepSpeech: v0.9.3-0-gf2e9c85
ERROR: Model provided has model identifier 'u/3�', should be 'TFL3'

Error at reading model file deepspeech-0.9.3-models.pbmm
Traceback (most recent call last):
  File "/home/pi/tmp/deepspeech-venv/bin/deepspeech", line 8, in <module>
    sys.exit(main())
  File "/home/pi/tmp/deepspeech-venv/lib/python3.7/site-packages/deepspeech/client.py", line 119, in main
    ds = Model(args.model)
  File "/home/pi/tmp/deepspeech-venv/lib/python3.7/site-packages/deepspeech/__init__.py", line 38, in __init__
    raise RuntimeError("CreateModel failed with '{}' (0x{:X})".format(deepspeech.impl.ErrorCodeToErrorMessage(status),status))
RuntimeError: CreateModel failed with 'Failed to initialize memory mapped model.' (0x3000)`

What’s the problem and how can I fix that?
I couldn’t find a solution on Google or at this forum, so I decided to create a new topic. If there is any explanation online that I just didn’t see, I’d appreciate it if someone posted it here.

I am pretty much a complete beginner with Rasperrys / Linux so any advice is really helpful. If you think that DeepSpeech is too much of a challenge for a beginner, please say it.

Thank you very much.

No worries, it can be complicated. But just today somebody linked a good post on how to run on Raspberry.

You used the desktop model .pbmm which is too big for such a small device. Use the .tflite version of the model instead and it should work.

Good luck and let us know if you have any other problems

1 Like

It works now!
Thank you for your advice.