Improving the function representation in the console


In the above image, web console shows the same name for both the doSomething function and the anonymous function returned by doSomething. It gets confusing to distinguish between the two and it also takes some time to see the definition in the sources.

I would like it to show the result of functionName.toString() and maybe a little hint like "returned by someFunction" on hover for any function returned by someFunction. If someFunction is anonymous, then the hint would be “returned by an anonymous function”.

Please let me know what do you think of it and if you like it, give more suggestions.

Hello @complexengine, thanks for the report.

I filed a bug for the issue about the name :