New Pad, New Paste

Hey, everyone -

I’ll be mentioning this in a company-wide email shortly, but I wanted the community to hear about it first. I’m very happy to be able to tell you about two tools that we’ve just finished standing up.

The first is a new, up-to-date version of Etherpad, stood up behind IAM:

With much gratitude for the Participation Systems and Open Innovation team’s work, backed by Adam Frank of Mozilla IT’s SRE Team, we’ve been able to get Etherpad brought up to a modern version, running on Mozilla infrastructure and protected behind IAM.

The old Etherpad has been out of date for a long time, and some bad people are using it for bad people reasons; I’ll talk some more about the decommissioning process later - we don’t want to orphan anyone’s work, for sure, so we’re not just flipping the switch immediately - but we’d like to make the switch soonish. I’ll be reaching out to the Reps and other community groups soon to work out what “soonish” means.

One perhaps-important caveat about New Etherpad: we’re treating it as a temporary data storage solution, not a permanent place for docs to live. Pads that are idle for seven days will be reset.

That “seven” number is also negotiable, and again I’ll be reaching out to the Reps and other community groups soon; we don’t want to commit to data in Etherpad being permanent, so we should have a discussion about it that I’m looking forward to.

The second thing is, we’ve also stood up a modern Pastebin tool!

There are a few differences here as well. This one isn’t behind IAM, because we often want to pastebin stuff from machines we shouldn’t put our credentials into. That said, our previous (also old, also crufty) version of pastebin didn’t have an SLA or official support and the options we offered included a “keep forever” option which turned out to be a huge lie that had never worked, so that was bad and we’re not doing that anymore.

As well, we don’t want our infrastructure to be arbitrarily misused by the aforementioned bad people, and definitely want the pulldown menus on the services we provide to not be full of lies, so the options available on our new pastebin are “one-time load, one hour or one day”.

Again, thanks to everyone on Participation Systems, the Open Innovation team and Mozilla IT’s SRE Team for their help and support getting this over the line.

  • mhoye

Thanks for this @mhoye

Communities will be happy to see these tools in a more stable situation :slight_smile:


1 Like

In mozilla pastebin the design of the title on mobile is broken. It seems that the title is too long for the page layout.

1 Like

Yuck. Ok, we’ll look into it, thanks for letting us know.

1 Like

@mhoye Login doesn’t work if using Firefox account, I guess that’s not expected.

1 Like

Hmmm. No, it isn’t. I’ll file a bug; thanks for letting me know.


Hi @mhoye I was trying to log in with google and I got this message
" Sorry, you do not have permission to access Please contact if you should have access."



Thanks for letting me know. We’ve got a bug filed for various login issues, so they should be sorted out shortly.

When I try to open/create the “test” pad in etherpad, I’m getting this error:

An error occurred
The error was reported with the following id: ‘L3p0XminW9EvqFwNToGB’
Please press and hold Ctrl and press F5 to reload this page, if the problem persists please send this error message to your webmaster:
‘ErrorId: L3p0XminW9EvqFwNToGB
UserAgent: Mozilla/5.0 (Windows NT 10.0; Win64; x64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/75.0.3770.100 Safari/537.36
Uncaught TypeError: Cannot read property ‘setChannelState’ of null in at line 3’

I’m running Nightly on Windows here, and I can’t reproduce what you’re describing; that URL gives me an empty pad called “test”. Is there anything idiosyncratic about your setup that might be causing you to see something different than I am?

Nah its working for now too, so it must have gotten fixed in the month between my message and your reply. (either that or it was just having issues the day I tried to view the test pad.)

Hey Mike,
volunteers are reporting that even when they are logged in they can’t access, could you look into it. Currently only NDA volunteers can access which is not optimal.

1 Like

I just activated 2FA and now I can log in normally with my Firefox Account

This may have unknowingly been made by an employee.

I sent Unable to access to and got this response from Riccardo Valabrega

Thanks for reaching out to us. You will need an NDA to be able to join the new istance.

There is more info here on the link, New Pad, New Paste

Thank you.

This needs to be fixed. @lucyeoh, @nukeador

1 Like

You will need an NDA to be able to join the new instance.

That should not be the case, but figuring it out and fixing it is my responsibility.

  • mhoye

The new etherpad should be now working with any account. I’ve just tested with my personal Firefox Account.

Yes. I can confirm too.