New version of extension approved, but not updated on the main site for a week, why?

I have updated my extension version to v1.3.0, it’s been approved, but it’s not been listed on the main site:

How is that? In my dev panel it says “Next version v1.3.0 listed but not updated on the main site”?

Why is that? The old version is buggy, I have made the fixes, it’s been approved, BUT NOT LISTED?

What’s the point of approving new versions of extensions if it’s not going to be listed on the main site?

You’re hurting my business, Mozilla is losing users because I have to tell my customers to go to use Chrome version of my extension to keep using updated version!

I have tried to reach Mozilla at twitter @mozamo no reply at all :angry:

I have made an extra effort to build the Mozilla version of my extension, gave access to the clean source code builds for security purposes and now Mozilla doesn’t give a damn about it!

Did you select “listed” at the very start of the upload flow? Because if you don’t select that, the version is for self-distribution (unlisted).

Edit: just noticed that the version is listed at https://addons.mozilla.org/en-US/firefox/addon/social-media-bot-auto-clicker/versions/, so not sure what exactly the issue is here. Possibly the new version is not yet signed or requires manual review.

The latest version listed is v1.2.9, the older one is listed as v.1.3.0, with recent data! How can this be the older version if the date is more recent and the version number is greater?

Am I missing something? Is it a bug in Mozilla extensions? Or is it delay on Mozilla side?

The exact status will be shown on the “Mange versions” page for the extension in “My Submissions”.

It’s been like this for a week. Approved. Not published. Why?

Anyone? Mozilla support?

Bump. Anyone? Is there any support here?

People will help you, but impatience tends to not make them want to help you more. In general, most people that work on AMO for a living probably just returned from vacation and are getting back into the rhythm. If you want real-time answers, I’d recommend a synchronous communication form.

But what’s the problem? There is a lack of communication in this matter.

  • Extension was approved

But:

  • Not published

Maybe there should be some clear information, this is a regular procedure at the dev panel, and that approved extension needs extra approval for whatever reasons?

Hi @PELock, thanks for your patience. This is a rare, weird issue that we’ve only seen once or twice.

Can you please file an issue with your add-on name and time of submission so we can investigate this further? You can also try bumping your version number and resubmitting to see if it goes through this time; if it doesn’t, we should be able to fix this for you.

Thanks!

No problem, I just wish I knew what’s wrong

Problem was ehem solved, when I have submitted new v1.3.1 version :wink:

  1. Bump the version
  2. Submit it again
  3. Wait 10 minutes (this is where the bug is, don’t do it too fast after submission)
  4. Modify description