No module named 'ds_ctcdecoder'

followed through all the steps in documentation. I am trying to trained it for Latvian language from common voice. processing of the data from was smooth. --helpfull gives this module not found error for ‘ds_ctcdecoder’. Please help.

You probably just got bad luck and cloned and ran the pip install step in the mean time between when DeepSpeech 0.7.1 was released and the ds_ctcdecoder package was built by the CI infra. It should have showed an error though, did you ignore it? In any case, installing again should work now, as all CI builds are done.

so i should install the 0.7.1 version of deepspeech sir. Is that correct ?

I’m saying given the timing of your message here and the release, it seems possible. But you haven’t provided information on exact steps you followed and the logs, so I can’t say much more.

issue solved sir. Thank you.

Would you care enough to share what solved it? It could be useful to other people …

Sure. I downloaded the .whl file for ds_ctcdecoder from deepspeech release site, the one that suits my current os setup. One just needs to find the version that suits theirs and just install it using pip in the virtual_env. Thats all. Ready to go.

No, this should be dealt by the setup phase. You have not fixed, you have workaround the issue, and now we cannot know if there was a legit issue other people will run into or if it was just bad timing as suggested by @reuben

That sounds reasonable. I will go through the setup phase once again and get back.

I am facing the same issue. Also,
ModuleNotFoundError: No module named ‘training’

is it no module named ‘deepspeech_training’ ?

1 Like

The path given is wrong in

Yes. I changed it to training.deepspeech_training import train. But again in the path for ds_ctcdecoder is wrong

I am not sure about a logical fix, but don;t change the existing code, just past the deepspeech_training directory where the python file is there… Changing one line of code may not reflect in whole script. Try that, it worked for me.

1 Like

symptom of “i have not ran the pip install step”

don’t change anything, follow the doc, and be clear in your report, you are mixing many things here…

1 Like