Not loading or adding jpegs in Firefox Color


(Mcnerdo56) #1

They’re under 1mgb. It says processing and then nothing. I’ve done about 6 themes so far and now I can’t do any without adding an image.


(Caitlin Neiman) #2

Hey @mcnerdo56! Have you tried uninstalling and reinstalling the Color extension?

If that doesn’t work, you may need to clear your local storage.

Keep us posted!


(Mcnerdo56) #3

I tried the uninstall and reinstall method before and it doesn’t work. Sometimes I can get a jpg to install but it’s like 2 times out of 8. How do I clear the local storage?


(Mcnerdo56) #4

Saw this response on the provided link:

“We were able to solve this by going to color.firefox.com, opening the storage inspector, deleting all from Local Storage, uninstalling the extension, and then returning to color.firefox.com to reinstall the extension.”

Question: How do you do what she just said? I mean how do you open the storage inspector in color.firefox.com to delete all from Local Storage?


(Martin Giger) #5

(Caitlin Neiman) #6

Sure! Sorry, I should have included more specific instructions. Here’s a breakdown of how to do this:

  1. Go to color.firefox.com
  2. In Firefox, go to Tools --> Web Developer --> Storage Inspector
  3. On the left hand side of the inspector, click the arrow next to Local Storage. You should see https://color.firefox.com underneath it.

  1. Right click on https://color.firefox.com in the storage inspector and click “Delete All.”

Delete%20All

  1. Go to about:addons and uninstall Firefox Color

  2. Go back to color.firefox.com and reinstall the extension


(Mcnerdo56) #7

Ah ha… sort of a jpg cache clearer. I picked an image that wouldn’t load, then went thru the steps that you showed. Perfect. I guess that’s the procedure now after 4 or 5 pic’s. Thank you so much for taking the time to answer and for the help in solving this.


(Caitlin Neiman) #8

Glad to hear that worked! :slight_smile: Happy theme making.


(Pamela Rosensteel) #9

I just ran across this problem as well, so thank you for posting the solution.

I wasn’t expecting it to delete all my saved themes, but now that I’ve saved a few more and checked the local storage again, I see that that was basically what was there … all my saved themes. Is there perhaps a limit to the number of saved themes before it might cause this issue again?


(Martin Giger) #10

I believe the issue is that there is a maximum amount of things a website can store there, and as soon as you’ve filled that up (quite quickly with images, I’d imagine), you can’t store any more.


(Ma Donnas Personas) #11

I had this problem several months ago and Caitlin worked one night at home to figure it out…all thanks go to Caitlin! :heart:


(Caitlin Neiman) #12

+1 to what @freaktechnik said. We’re working on getting resources to continue development for Firefox Color, and this bug is on the list of things that we’d like to fix.