Pdf open don't save

Hallo, seit kurzem speichert FF pdfs die ich öffne automatisch - ich sehe keine einstellung um dies z verhindern?! Ich öffne die pdfs mit einer externen Anwendung. Automatisch speichern ist aber unnötig - muss ich wieder löschen und evtl. auch gefährlicher?
Danke für jede Hilfe!! :slight_smile:

You can change from “Save File” to “Always Ask” or “Use Acrobat” (https://support.mozilla.org/kb/view-pdf-files-firefox-or-choose-another-viewer) but this will not change where Firefox saves the file.

In earlier versions, when you selected “Open with [application]” Firefox saved the file in the system TEMP folder, and passed that path to the application. Some users complained of losing their download (especially in cases that it was not available again) due to where the file was saved.

So in Firefox 98, the Downloads folder is used always instead of the TEMP folder being used sometimes.

There might be an option to change this in a future update, but I have not been following the recently filed bugs.

thanks for your help!!


there is a related issue that I’d like to solve.

What I normally do is open the PDF with the Firefox Built-In Viewer in a new tab with the “Open with Firefox” setting. That works.

But when I clicked on the download button in the Builtin-In Viewer before, it used to give me the option to either download it to a folder or to open it with Adobe Reader.

But now, it doesn’t give me the option anymore. It automatically opens Windows Explorer for downloads.

How to I get the download button of the Firefox Built-In PDF Viewer to give the option of opening with Adobe Reader again? Is this a Firefox issue or a Windows issue? I suspect this is a Windows issue somehow, but I thought I would ask anyway.

I’m using Firefox 98.0.1 on Windows 11.

Thank you for your time.

This seems to be a missing option in Firefox’s PDF handling. For other types of files, you can select “Always Ask” to get the traditional Open/Save/Cancel dialog. But if you assign that for PDFs, then you can’t use the built-in viewer. Hopefully there will be a solution for this Catch-22 in the future.

1 Like

I’d love that. My downloads folder is full of PDFs I just quickly read while browsing the web.
I never intended to download them. Then I’d have specifically chosen to save it – instead of opening it with Firefox – in the “always ask” popup. Even the option to view it with the default PDF reader does the same. Junk in my Downloads folder…

Is it this way with every download? I also regularly delete zip files I opened to extract them to wherever I wanted to extract the files.

The Temp folder option was added in Firefox 102. Check out the solution here:

1 Like