Platform error with local setup

Hi, I am trying to setup a local instance of CV. When I access it on the server (through localhost:9000) it work just fine.
But when access from other computers through IP:port, it show up like this. Obviously, am using lastest Firefox. Chrome doesnt work either.

This is the message you get when your user-agent is iOS or webRTC is disabled, since it’s used for recording clips.

I’ve searched google about how to enable weRTC, and followed those steps:

  1. Type “about:config” into the address bar and hit Enter.
  2. Click the button “I accept the risk!”.
  3. Type “media.peerconnection.enabled” in the search bar. Only one entry should appear.
  4. Right-click on the entry and choose “Toggle” to change the Value column to “true”.

… but still, the same error. Am not using iOS btw, am using Ubuntu

#update: I’ve tried Firefox and Chrome on Windows10, Android, still have this error

@nmstoker @xdumaine is this something you’ve seen yourselves when deploying locally?

Actually yes, I do see this and for me there’s a simple work around - not sure how applicable it’ll be for @nthanhha261 but here’s how it occurs for me:

I use Ngrok in order to make it simpler to use with https on my mobile phone (Android) as the client. If I try to access the site via the http address I get this, so I have to make a point of starting on the https link. I’ve got the Ngrok URL protected by a password, and also use the Profile login feature.

A minor inconvenience is that when I login to my profile, even if I’m already on https it always initially sends me to the http page to start speaking and that triggers the exact message shown in the screenshot. I simply switch it back to https in the address bar and it is fine (with my Profile still loaded etc)

If using Ngrok or similar is an option then I’d suggest trying that (unfortunately I can’t recall if https is available on the free level, I’ve got a paid account). The other thing that might work (but I haven’t tried) would be seeing if self signed certificates for https could work in this case for local use.

I hope that’s a start at least.

1 Like

I’ve not hit this issue with this particular project, but I’ve been working with WebRTC and getUserMedia for years, and you’re spot on - https is required. The solution I’ve used in the past is to use a self signed certificate generated dynamically on project boot and serve everything on https. This does add the inconvenience of insecure webpage warnings unless you install a trusted root certificate that you use to generate the ssl certs.


Yeah, I think https is required. But unluckily, am unable to config https for my website (I’ve tried for 2 months) so I end up doing tricks with Firefox’s config.
After I toggled media.getusermedia.insecure.enabled and media.devices.insecure.enabled to true, everything work!
And, I got the same problem as you when doing https, before Login, the page is https but after that, Auth0 redirect me to http. In my case, switch back to https in address bar will logged me out

  • Can this be a limitation for local development?
  • If so, can someone summarize the problem in one sentence so it can be reported on github?

Thanks everyone!