Remote Debugging - waiting for browser

Hey,

I’m trying to get remote debugging up and running but I’m stuck with “waiting for browser”

I’m using the German Nightly in x64 on my desktop and the Firefox Nightly on Android (play-store).

The following forum thread sadly didn’t help me :confused: (so this is a continuation of that thread sort of):

Remote Debugging

ADB (USB) is activated in the Android settings and adb devices lists my device.
remote USB Debugging in the settings of my Firefox (Android) is turned on.

The two checkmarks in the settings of my inspector for remote debugging and addon development are checked.

I open about:debugging and activate the tools.
The phone shows up on the left but is stuck in waiting for browser.

The following command didn’t work out for me (is it still necessary?):

adb forward tcp:6000 tcp:6000

I know of two manuals, one seems to be outdated:


I never saw an incoming connection dialogue on my phone.

Daylight and Nightly are installed on my phone. At the moment only Nightly has remote debugging (usb) turned on.

What else could I check, what could be the problem here?

Regards
Felix

Update: I tried reconnecting my usb cable.
It disconnects and then is stuck again in waiting for browser.

Network/Wifi doesn’t work either

I even enabled devtools.remote.wifi.enabled

I have same problem too. Firefox Developer Edition on Linux (Fedora) and Firefox Nightly on Android. Both of them are latest version.

Hi,

Note that you can’t debug Nightly from Dev Edition. The client (desktop FF) should always be the same version or more recent than the server (mobile FF). Nightly is always more recent than DevEdition.

That being said, you should still be able to see the Browser (just tried right now).

Make sure you have both USB Debugging enabled in Android settings and in Firefox Nightly settings. Older versions of Fenix required to have a tab opened to see the browser, but I don’t think this is the case anymore.

Hi!

This page is completely outdated and should be removed https://developer.mozilla.org/en-US/docs/Tools/Remote_Debugging/Firefox_for_Android

You don’t need to run any adb command to setup remote debugging. It looks like you have enabled USB debugging in Android settings (I don’t think you would see the phone otherwise). Maybe try disabling USB debugging from about:debugging. Kill any adb process still running. Then re-enable USB debugging?

Can you share which phone you are using here?

(unfortunately we don’t have a good way to get connection failure logs here :frowning: )

Thanks for trying to help :slight_smile:
I’ll test out your suggestion.
I’m running a oneplus 3T with a custom rom (Android 10)

adb.exe (the Plattform tools) need to be in the system path still (right?)

good to know that it’s supposed to work automatically now (Firefox calls adb.exe now)