Remote Debugging

I want to be able to debug a site on my Samsung Galaxy A6 remotely. My phone has been found on the left under about:debugging#/setup but it is stuck on “waiting for browser” and I have no idea why. Thanks

Hi @knutsford-software!

Which browser do you want to debug? I assume Firefox Preview?
If this is the case, try opening a tab on Firefox Preview, sometimes the browser doesn’t become available until a tab is open.

I had a bug filed to improve this: but I didn’t get to it yet.

Let us know how it goes!

I had spotted that bug when I was googling. I am glad I am not the only one with the problem. I don’t really mind which browser I use as long as I can debug JavaScript and Jquery. I just searched for Firefox in finder on my phone so I am guessing that is FireFox Preview. I tried Chrome and my Chrome brower on my Desk top but in taht case it didn’t find my Phone

Great! make sure you use Firefox Preview. The old “Firefox for Android” is based on a very old Firefox version and will not work for remote debugging (it should be replaced by Firefox Preview soon).

opening a new tab didn’t make any difference. Is there was way of JavaScript debugging via the actual mobile? I gather there isn’t.

Ah - do I need to download FireFox Preview on my Phone then?

Yes, that’s the best solution here.

The old Firefox For Android has “remote debugging” disabled by default (that’s why it doesn’t show up in the sidebar). As mentioned in , you have to enable USB remote debugging in the advanced settings of the application. But as I said, it’s too old to be used with your current Firefox Desktop, so try to use Firefox Preview instead.

Still not working with preview either :frowning: Even with a new tab

I just checked and USB debugging is also disabled by default on Firefox Preview. Can you open the settings of Firefox Preview ("…" menu on the bottom-right) and check if Remote USB Debugging is on or off?

Brilliant - thanks. That worked

Thanks for updating us, glad it works now!

So am I. It didn’t display any JQuery errors unfortunately . I was hoping it might give me a clue why a slider won’t drag if you look on a mobile. O well it will be usefull for another time

Glad remote debugging worked out. Might be useful to highlight further which browsers can be debugged.

Does your slider problem reproduce using the Responsive Design Mode on desktop?

Yes it does. Does that explain the problem? Is it CSS somehow then as I suspect.

If I disable the Touch Simulation it works and you can drag the slider

Ah -

Thanks for mentioning Responsive Design Mode - I hadn’t realised it existed. That will be very useful