Run setup.py failed

Hello mozlla team!!!
You are done so greate work.

But I reached an issue about unable to run the setup.py script
Here is the command I use to run the setup.py script
sudo python setup.py install

And here is the output

deepspeech-training 0.10.0a3 is already the active version in easy-install.pth

Installed /usr/lib/python3.10/site-packages/deepspeech_training-0.10.0a3-py3.10.egg
Processing dependencies for deepspeech-training==0.10.0a3
Searching for ds_ctcdecoder==0.10.0-alpha.3
Reading https://pypi.org/simple/ds_ctcdecoder/
No local packages or working download links found for ds_ctcdecoder==0.10.0-alpha.3
error: Could not find suitable distribution for Requirement.parse('ds_ctcdecoder==0.10.0-alpha.3')

It saies could not find the version of ds_ctcdecoder and I tried the 0.9.3 version and the 0.10.0a3 version which is the newest version the pipy provided but I still got the same error

Which version should I use ? Thanks you all!!
best wishes from zheng ma!!!

The versions of python and the pip I used is the latest version!
And My os is manjaro system (linux)