Setting Up Kuma


(Calum1904) #1

Hey so I’m setting up Kuma following the guide found here and I have got to this line of code

docker exec -i kuma_web_1 bash -c "zcat | ./ dbshell" < mdn_sample_db.sql.gz

But every time I run it I get

gzip: stdin: unexpected end of file
: No such file or directory

Just wondering if anyone can help me get past this.

When downloading the DB I had to use

wget -N --no-check-certificate

As I couldn’t get it to verify, could this be what caused the issue?

(Chris Mills) #2

@Ryan_Johnson, can you help with this one?

(Ryan Johnson) #3

Yes, I’d be happy to Chris!

Hi calum1904,

Could it be that your “mdn_sample_db.sql.gz” file is not in the same directory as the directory in which you’re running the “docker exec …” command? Did you run all of the commands listed in the documentation in your “kuma” directory?

Hmm, I don’t know why you had to add the “–no-check-certificate” option to the “wget”.


(Calum1904) #4

Hi @Ryan_Johnson! thanks for your reply, I believe it’s in the correct location I’ll attach a screenshot below. I did all the commands listed docker-compose up -d -p kuma didn’t seem to do anything.

(Calum1904) #5

Right so update, I managed to change the error I was having to

Error response from daemon: Container a22f97f2606a66a133be3481c63213faa6581446371152fb007c796cd4a953d0 is not running

But when I now do

docker-compose up -d

I get error

(Jwhitlock) #6

calum1904, I’m sorry you’re having trouble running the Kuma install instructions. Unfortunately, I’m not a Windows user, so I can’t replicate your problem.

You may want to look at the Docker for Windows docs, and run through the examples, to make sure the basics are working:

Docker appears to have trouble finding files like “” that are mounted from the Windows disk into Docker. You may need to authorize sharing your C: drive with Docker, which may take the extra steps in the “Shared Drives” section: