Size mismatches in released model

Must be doing something stupid here. Trying to run one of the released multispeaker models:

Multi-Speaker-Tacotron2 DDC VCTK 2136433

when I checkout 2136433 and try a test with I still get a bunch of layer size mistmatches.

size mismatch for decoder.attention_rnn.weight_ih: copying a param with shape torch.Size([4096, 1024]) from checkpoint, the shape in current model is torch.Size([4096, 896])

(seems to be a delta of 128)…tried a few other commits around the time of the model and no luck. Can anyone point out my mistake?

EDIT: I also noticed that the link to Universal WaveGrad on the wiki doesn’t point to a google drive link like the rest of the vocoder models. Would like to try it if possible.

you need to use the right commit version with those models. Commit versions has been given on the table.

Thanks erogol,
I checked out 2136433 (21364331d22b09a347bb069f98744dea78ca899f) when I tried, do I have that wrong?

Ah, I think the commits on the wiki differ from the notebooks? For the two tacotron2 multispeaker models:

!git clone TTS_repo

%cd TTS_repo

!git checkout ea976b0


Things seem to work fine with ea976b0.

1 Like