[SOLVED] Certificate error when accessing mysubdomain.mozilla-iot.org

(David D.) #1

Perhaps I don’t understand how subdomains at mozilla-iot.org work, but when I try to access one that I have previously created using a web browser (via the url https://mysubdomain.mozilla-iot.org, for instance), I get the following error:

SSL_ERROR_ACCESS_DENIED_ALERT

Is that supposed to happen? Are no web services provided by these domains? Are they controlled entirely by gateways using other protocols?

[UPDATE:] I have been conducting these experiments behind a proxy/firewall that uses a certificate generated by our local domain’s certificate authority, an authority that is not verifiable through any other certificate authority. In effect, a self-signed certificate is in the chain of communication between local devices, including from the gateway and web browsers on other devices, and the mozilla-iot.org domain. This appears to be the reason that communication is refused by mozilla-iot.org. Later on, I will investigate work-arounds for this problem, but as long as I conduct my experiments from networks that don’t go through proxies that inspect SSL communications, I have no problems.

[SOLVED] How to reclaim a domain at mozilla-iot.org?
(Rzr) #2

yes this part seems fragile, for some reason I am failing to reclaim my previously created domain…

Is there a way to reset the gateway config ? rm -rf ~/.mozilla-iot ?
then I can provide log,