SSL error and reclaim domain procedure not working


I was able to access my gateway for the first couple of weeks after install but then started getting the following SSL error when using the subdomain URL:

An error occurred during a connection to Peer received a valid certificate, but access was denied.


gateway.local still works just fine on my local network, have tried rebooting and but keep getting error. Have read the threads here and here but neither seem to apply to me.

Tried the reclaim subdomain steps here but fails on step 2 when I navigate to https://gateway.local:8080/subscribe, I just get a blank blue page with only the menu and add device icons. Is there any other way I can get my subdomain back?


You don’t need to manually make calls to the registration server API. That’s all done by the gateway itself.

The issue you’re getting indicates that your tunnel is not currently connected. Try doing the following on your RPi:

sudo systemctl stop mozilla-iot-gateway
sqlite3 ~/.mozilla-iot/config/db.sqlite3 "DELETE FROM settings WHERE key = 'tunneltoken'"
rm -rf ~/.mozilla-iot/ssl
sudo systemctl start mozilla-iot-gateway

Then, open a private browser window (so that nothing is cached) and navigate to http://gateway.local or http://gateway.local:8080. You should then be back at the subdomain setup screen. If you enter the same subdomain and email address that you initially did, your domain reclamation should work fine.

Awesome, thanks. I’ll try that when I’m back home later in the week.

That hasn’t worked at all, can’t even access it at https://gateway.local:8080 now. Now getting:

Secure Connection Failed

An error occurred during a connection to gateway.local:8080. PR_END_OF_FILE_ERROR

1 Like

You’re trying to access port 8080 as https. That will not work.