[Support] Copy PlainText


(erosman) #1

Please post your support questions about Copy PlainText here.

Thank you


(Afroaghao) #2

it would be really nice if you could offer an option to copy as plain text by default (e.g. when user presses Ctrl-c). in such a case, the context menu entry shouldn’t be added, either.


(erosman) #3

Sadly, WebExtension API is very limited and I am not sure if that would be possible.
If it can be done later, I will add the feature.


(Primokorn) #4

Any news about this option?
Thank you!


(erosman) #5

Nothing yet … a hack is possible (by intercepting copy commands) but that adds a lot of processing to each page and often gets blocked by the JS script of the page.

I added a keyboard shortcut (F7) which is easier than (Ctrl + c) without affecting Firefox or JS on the page.


(Primokorn) #6

F7 is already used on my end so I have to use ctrl + shift + F7. Could you let users choose the shortcut key•s?


(erosman) #7

That would have been good but not possible at the moment with WebExtension API but there is a request for it (https://bugzilla.mozilla.org/show_bug.cgi?id=1215061)


(John Hill) #8

It seems to me that CopyPlainText is limited to about 181 characters. If I try to copy more, I get an error report.
Is this a genuine limitation? And if it is, can it be extended?
I regularly perform a copy that exceeds this size and it presents a serious handicap.


(erosman) #9

It doesn’t happen to me. I just tried a text that was 5354 characters after the Copy PlainText operation.
I am using FF56 which uses a different copy method but I cant think why that would be the case.


(John Hill) #10

Curiously, it has started to work this morning! I wonder if I changed something somewhere? Anyway, I have just managed to get it to copy 2670 characters after paste.
But it will only work with the right-click pop-up menu; I cannot get anything to copy with F7 or ctrl-shift-F7. These leave the original content of the clipboard unchanged.
I am using FF55 on a mid-2007 iMac, El Cap (the end of the road for this iMac).


(erosman) #11

The way WebExtension Keyboard commands work is that in case of conflict only one command is registered. That means if another addon or browser process registered the same keyboard shortcut, only one will get it and others won’t.

It could also be that the Function keys don’t work on Mac or older Mac.

I don’t have an iMac to test it on. Check the browser console to see if there are any indications when starting the Firefox or after disabling/enabling the addon.

PS. On Macs, “Ctrl” is interpreted as “Command”.


(John Hill) #12

No, command-shift-F7 does not work either. In fact, I’ve tried all sorts of combinations of command, option, control and shift with no effect.
I cannot find anything in Console that is in the least relevant - certainly disabling and enabling CopyPlainText produces nothing.
But control-click and right-click both work, so I will settle for that.


(John Hill) #13

Further to my last message, I have now discovered how to get F7 and command-shift-F7 to work.
If I go to System Preferences/Keyboard there is an option “Use all F1, F2 etc. keys as standard function keys”. If I check this option, F7 and cmd-shift-F7 work in CopyPlainText; if I uncheck it, they do not.
Might this be worth including in the documentation of CopyPlainText?


(erosman) #14

Indeed … I made a note in addon’s description.

Thank you for finding it out.


(John Hill) #15

Glad to help. I like your addition to the documentation.

In the email that came, you wrote “Would you know if that only applies to old iMacs or all Apple systems?!!”.

All I can say is that the same preference option appears in my wife’s iMac, which is a 2009 model. Mine has a USB keyboard, whereas hers is wireless. We are both using the same OS version. Later models may differ, but knowing Apple, the option will be unlikely to appear if it is not necessary.


(Lbotka2) #16

I use caret browsing (moveable cursor) : F7 disables it without notification or enables it after replying “Yes” for the caret browsing popup. It can be set in Options - Browsing - “Always use the cursor keys to navigate within pages” too.
Both the caret browsing function and the copy is executed,
and if there is no text selected, as usual in my case, when I don’t want to copy, I get the error popup “there was an error with this operation”.
Because of this, I ask for an option, to disable F7, Ctrl-Shift-F7 is enough for me.
I use Windows 10, FF 56 and FF 57beta.


(erosman) #17

At the moment, there is no API to enable users to change the keyboard shortcuts set in WebExtensions.

When I was testing on pre FF57, the extension shortcut F7 would over take caret browsing. On FF57 it doesn’t.

The keyboard shortcuts are extremely crowded and it is hard to find one that doesn’t conflict with Firefox or other extensions (unless using 3 key combinations and even those are crowded).

I have been planning to replace F7 with something else anyway but I am not sure what! :thinking:


(Lbotka2) #18

Thank you.
In the meantime I discovered, that with the config setting “accessibility.browsewithcaret_shortcut.enabled” I can disable the F7 shortcut for the caret browsing function, so a F7 can’t enable/disable caret browsing accidentally, only Copy Plaintext will use it.


(John Roblin) #19

Can I have confirmation that Copy PlainText is no longer working after the recent FF update? Thank you.


(erosman) #20

Sorry… I don’t understand.

It is working fine with FF53-57
The keyboard short cut F7 conflicts with a Firefox shortcut. The alternative keyboard shortcut “Ctrl+Shift+F7” works fine.

The context-menu also works fine.

If there are any issues, I would certainly fix them. :slight_smile: