[Support] Flash Control


(blueskyy) #21

[quote=“blueskyy”][quote=“tingo”]
Can I remove something manually — say in the Profile/xxxx.default/extensions directory? …

OK, now I’ve disabled the extensions… but with AiOS disabled I got what I guess is your full settings panel back, i.e. not with an empty whitelist and with those two boxes checked:

http://www.casimages.com/i/150225113357283725.jpg

But… it still made no difference: not a sign of your icon, YouTube videos start without being asked. And now there is a further problem, after I reactivated AiOS: once I open your Flash Control panel, it won’t let me close the sidebar again, either using the x, F4 (default in AiOS), or hovering out of it (custom setting in AiOS). Moreover, if I open other items in the sidebar (say the History or the Bookmarks), when I try to quit these with one of the methods above, your panel comes back instead, stubbornly.

So right here and now, I had no other choice than to disable Flash Control. Very unfortunate, because I had been making good use of it. I hope you can figure all this out, don’t be afraid to ask (but I’m no programmer).[/quote]

No, you shouldn’t be removing anything manually, that is against all guidelines.

My test the other day yielded the opposite result. Flash Control was already on my system to start with when I installed AIOS. After installation of AIOS, I have no control over the sidebar, I cannot open Flash Control settings panel from the toolbar, could only “manage” it through AIOS. Flash Control can be opened, but the settings are blanked. However, it worked just fine with youtube.

If Flash Control is that much trouble to get it to work with AIOS, I suggest that you uninstall it completely instead of disabling it and leaving it on your system. There are tons of extensions out there, that’s the beauty of Firefox, find one that works with AIOS.

ps: Firefox just upgraded itself to 36.0 today. Developer Edition was actually at 37.xx when I tested AIOS.

– edit –

When you right click a video on youtube, does it show you the Flash context menu or the HTML5 menu?[/quote]

From the old support thread.


(blueskyy) #22

[quote=“tingo”][quote=“blueskyy”]

No, you shouldn’t be removing anything manually, that is against all guidelines.

My test the other day yielded the opposite result. Flash Control was already on my system to start with when I installed AIOS. After installation of AIOS, I have no control over the sidebar, I cannot open Flash Control settings panel from the toolbar, could only “manage” it through AIOS. Flash Control can be opened, but the settings are blanked. However, it worked just fine with youtube.

If Flash Control is that much trouble to get it to work with AIOS, I suggest that you uninstall it completely instead of disabling it and leaving it on your system. There are tons of extensions out there, that’s the beauty of Firefox, find one that works with AIOS.

ps: Firefox just upgraded itself to 36.0 today. Developer Edition was actually at 37.xx when I tested AIOS.

– edit –

When you right click a video on youtube, does it show you the Flash context menu or the HTML5 menu?[/quote]

I use several extensions to download YouTube and other videos (to watch them offline, because my connection goes through frequent hiccups), but yours stopped the video’s automatic startup in YouTube before I started dowloading them. In that your FC seemed pretty unique, but please correct me if I’m wrong (and point me towards another extension that does the same thing, if you’ll be so kind.)

Until this morning, it’s not like I was having the least trouble between Flash Control ands AiOS, it’s just that FC suddenly stopped working after several months without a glitch. Nothing says whether it’s due to AiOS, actually that’s a bit doubtful, considering that disabling AiOS didn’t reinstate FC’s functionality.

There will go a few days before I install 36 on my working machine: I always test a new version on a secondary machine, in order to avoid problems like the bad memory leak we experienced with some earlier version (25, was it?)

This is what I get when I CTL-click (my own setting, I’m a bit old-fashioned in this respect) on a YouTube video:

http://www.casimages.com/i/150225031420445042.jpg

That will probably say more to you than it does to me.[/quote]

From the old support thread.


(blueskyy) #23

[quote=“blueskyy”][quote=“tingo”]
… In that your FC seemed pretty unique, but please correct me if I’m wrong (and point me towards another extension that does the same thing, if you’ll be so kind.)

This is what I get when I CTL-click (my own setting, I’m a bit old-fashioned in this respect) on a YouTube video:

http://www.casimages.com/i/150225031420445042.jpg
[/quote]

I’ve checked the changelog for v1.2.8. One of the changes is this:

More efficient handling of Flash contents with
regards to the Flash plugin's state.

And it got me wondering, what does your Flash plugin settings show? Does it show “always activate”?

To be perfectly honest, I’ve only ever used 2 flash blockers, FlashBlock and this, Flash Control. BUT, I have come to know recently that NoScript has Flash blocking capabilities as well. There are of course others, just do a search.[/quote]

From the old support thread.


(blueskyy) #24

[quote=“tingo”][quote=“blueskyy”]

And it got me wondering, what does your Flash plugin settings show? Does it show “always activate”?[/quote]
No, they’re set to “Ask to activate”.

[quote=“blueskyy”]
To be perfectly honest, I’ve only ever used 2 flash blockers, FlashBlock and this, Flash Control. BUT, I have come to know recently that NoScript has Flash blocking capabilities as well. There are of course others, just do a search.[/quote]

I believe I did give a try to FlashBlock about when I came across your Flash Control, but something wasn’t working, or satisfactory, can’t remember.

I have just uninstalled Flash Control and re-installed it, but it’s still not working. So right now, I’ve figured this work-around: reset Fx’s plugin (i.e. removed “Allow and remember” for YouTube) and set NoScript to only “Temporarily allow” YouTube (there might be some other settings in NS, as you suggest, but it’s a bit too complex for my ole head). For good measure, I’ve added the extension Flash OnOff, which appears to work. It’s all rather clumsy, not nearly as elegant as Flash Control, but it does what I want… so far.

I hope that in time you’ll have a “revelation” as to what what caused the problem. If you do, please remember this thread, so that I’ll know that I can give a try to your FC again. Thanks for your helpfulness.[/quote]

From the old support thread.


(blueskyy) #25

[quote=“blueskyy”][quote=“tingo”]
No, they’re set to “Ask to activate”.
[/quote]

That probably explains it. When you set the Flash plugin to “Ask to activate”, the default behavior is to let Firefox handle it. This change was made starting from v1.2.8, so that a user doesn’t have to manage a site twice, once in Flash Control, and once in Firefox “Click to Play”. That is supposed to be a feature of Flash Control.[/quote]

From the old support thread.


(blueskyy) #26

[quote=“tingo”][quote=“blueskyy”][quote=“tingo”]
No, they’re set to “Ask to activate”.
[/quote]

That probably explains it. When you set the Flash plugin to “Ask to activate”, the default behavior is to let Firefox handle it. This change was made starting from v1.2.8, so that a user doesn’t have to manage a site twice, once in Flash Control, and once in Firefox “Click to Play”. That is supposed to be a feature of Flash Control.[/quote]
Not sure I understand, sorry. But if you tell me what it should be set to, Always or Never activate, I’ll give FC another try.[/quote]

From the old support thread.


(blueskyy) #27

[quote=“blueskyy”][quote=“tingo”]
Not sure I understand, sorry. But if you tell me what it should be set to, Always or Never activate, I’ll give FC another try.[/quote]

If you want Firefox to manage Flash using its native “Click to Play” (that’s what it’s called), choose “Ask to Activate”. If you want Flash Control to manage Flash instead, choose “Always Activate”. That’s why I keep telling people that Flash Control doesn’t interfere with anything, not other extensions, not Firefox. Ideally, users should not be managing the same component over multiple interfaces. That my design philosophy.

For Flash plugin, “Always Activate” is the default, isn’t it? That was the case for the Developer Edition (37.xx.xx) and the Nightly (38.xx.xx).[/quote]

From the old support thread.


(blueskyy) #28

[quote=“tingo”][quote=“blueskyy”]

If you want Firefox to manage Flash using its native “Click to Play” (that’s what it’s called), choose “Ask to Activate”. If you want Flash Control to manage Flash instead, choose “Always Activate”. That’s why I keep telling people that Flash Control doesn’t interfere with anything, not other extensions, not Firefox. Ideally, users should not be managing the same component over multiple interfaces. That my design philosophy.

For Flash plugin, “Always Activate” is the default, isn’t it? That was the case for the Developer Edition (37.xx.xx) and the Nightly (38.xx.xx).[/quote]
Well, that seems to have fixed it — your FC is working again here. You see, I guess I’d had Flash set to Ask to Activate like “for ever”, because of its countless security issues, or because it was the only way to keep some videos from running (such as my local weather report, which launches a yacketing person without being asked and… reloads the page automatically every so many minutes!).

I reinstated everything as it was before my previous reply, except for NoScript: by default (?), it had Forbid Adobe Flash checked, and that was now giving some weird glitches (video not playing after clicking FC icon, or blank page opening instead).

Anyhow, I hope some of this will make it into your FAQ. I’ll be back if anything funny happens again.[/quote]

From the old support thread.


(blueskyy) #29

[quote=“blueskyy”][quote=“tingo”]
Well, that seems to have fixed it — your FC is working again here. You see, I guess I’d had Flash set to Ask to Activate like “for ever”, because of its countless security issues, or because it was the only way to keep some videos from running (such as my local weather report, which launches a yacketing person without being asked and… reloads the page automatically every so many minutes!).

I reinstated everything as it was before my previous reply, except for NoScript: by default (?), it had Forbid Adobe Flash checked, and that was now giving some weird glitches (video not playing after clicking FC icon, or blank page opening instead).

Anyhow, I hope some of this will make it into your FAQ. I’ll be back if anything funny happens again.[/quote]

I’m just glad it’s resolved.[/quote]

From the old support thread.


(blueskyy) #30

[quote=“roger21”]hello and thanks for your addon,

in the descriptions you talk about “flash player”, while it is probably the right term, it’s confusing because it leads to think that you only block “flash videos” instead of “flash contents” … … … so that is done (you can hate now)

so more seriously i have several questions:

  • what are the F 1 L thingies under the whitelist in the sidebar (also in the screenshots you have a 2 that i don’t have myself), what do they do, can you add a “tittle” (as in tooltip) on them, explaining what they are or what they mean

edit: ok so i check the code, it’s the pager … so it’s not good, you should use << and >> and making them greyed when they are disabled … (more hate induced)

  • what “Ignore Flash Plugin State” does and when do i need it? (when i change the flash plugin permission i guess but then what does it do?)

  • is it possible to export/import the whitelist? it’s not in about:config and i didn’t find a file in the firefox profile that would contain it (there must be one) … anyway an integrated import/export feature (including the settings, why not) would be nice (but a file to save from the profile is good enough and of course a single entry in about:config - just like flashblock does - is fine too)

then hard stuff:

  • could you add the “source checking whitelisting” thingy that flashblock does, for instance i whitelist youtube and i like to have it allowed anywhere when it is embeded too, i think it’s really convenient

and finally (even more hate):

  • the sidebar is kinda ugly … could you use a “sans serif font” instead of the default one: in the css for the body you can add that for instance, that should do it “font-family:Verdana,Arial,Helvetica,sans-serif;” (i know you know, but i tried to add solution not just criticism) and also a background color could be cute or not … anyway another thing, the contextual menu of the sidebar … first, its not affected by the “classic theme restorer” options, making it unnecessary huge with the big buttons, but then can you disable it or make it relevant to the sidebar (i.e. not being the contextual menu of a webpage)

… i think that’s all …

thanks again (and sorry)

i like your addon, i mostly miss the “source checking whitelisting” thingy and an easy way to save/import the whitelist i think[/quote]

From the old support thread.


(blueskyy) #31

[quote=“blueskyy”][quote=“roger21”]

  • what “Ignore Flash Plugin State” does and when do i need it? (when i change the flash plugin permission i guess but then what does it do?)

  • is it possible to export/import the whitelist? … … anyway an integrated import/export feature (including the settings, why not) would be nice (but a file to save from the profile is good enough… …)

  • could you add the “source checking whitelisting” thingy that flashblock does, for instance i whitelist youtube and i like to have it allowed anywhere when it is embeded too, i think it’s really convenient

  • the sidebar is kinda ugly … could you use a “sans serif font” instead of the default one: in the css for the body you can add that for instance, that should do it “font-family:Verdana,Arial,Helvetica,sans-serif;” … and also a background color could be cute or not …


[/quote]

As discussed here, starting from v1.2.8, if the user changed the default Firefox settings, ie set the Flash plugin settings to “Ask to Activate”, Flash Control’s default behavior is to let Firefox handle it, and we are done there. If the user somehow, wanted to manage Flash over 2 ui interfaces: Firefox’s very own “Click to Play” and Flash Control, then he has to select “Ignore Flash Plugin State”. If the user had stuck with all the default settings, then he doesn’t have to change anything here.

Currently, it’s not possible to export any kind of settings from Flash Control. It is already in my todo list, but that’s not the only item on my todo list.

While I think I understand what you meant by “source checking whitelisting”, I don’t quite understood your illustration. It is already discussed here. That is also on my todo list. Right now (and has been the case since the first release), if you add “www.youtube.com” to the whitelist, all youtube embeded contents are affected to, ie the whitelist applies to them too.

If you like sans-serif font that much, I’ll just switch it to use sans-serif fonts in the next release.

– edit –

Sorry, I spoke too soon, I have to take back the last statement. I prefer serif font to sans-serif fonts in the sidebar. Unless I have time for an overhaul, it will remain as such. Sorry, I did NOT do that on purpose.[/quote]

From the old support thread.


(blueskyy) #32

[quote=“roger21”][quote=“blueskyy”]As discussed here, starting from v1.2.8, if the user changed the default Firefox settings, ie set the Flash plugin settings to “Ask to Activate”, Flash Control’s default behavior is to let Firefox handle it, and we are done there. If the user somehow, wanted to manage Flash over 2 ui interfaces: Firefox’s very own “Click to Play” and Flash Control, then he has to select “Ignore Flash Plugin State”. If the user had stuck with all the default settings, then he doesn’t have to change anything here.

Currently, it’s not possible to export any kind of settings from Flash Control. It is already in my todo list, but that’s not the only item on my todo list.

While I think I understand what you meant by “source checking whitelisting”, I don’t quite understood your illustration. It is already discussed here. That is also on my todo list. Right now (and has been the case since the first release), if you add “www.youtube.com” to the whitelist, all youtube embeded contents are affected to, ie the whitelist applies to them too.[/quote]

thanks for your answers

ok for the ignore thingy, it’s clear now

and good to know the export/import feature is in the todo list

about the source-based-whitelist of flashblock, i am actually confused about the iframed contents (which seems to work the same in flash control and in flashblock and which is what i want) and i’m not so sure anymore about what this flashblok’s option does, so nevermind i guess[/quote]

From the old support thread.


(blueskyy) #33

[quote=“roger21”]also

when you’re on about:home|blank|newtab or similar, the button is greyed so you can’t check your whitelist or manage it directly from the button when you’re on those page (you can use the menu to open the panel still but it’s less convenient)

so i was wondering if you could add the bottom part of the popup when the button is greyed (disable and open whitelist) i think that would be nice[/quote]

From the old support thread.


(blueskyy) #34

[quote=“blueskyy”][quote=“roger21”]also

when you’re on about:home|blank|newtab or similar, the button is greyed so you can’t check your whitelist or manage it directly from the button when you’re on those page (you can use the menu to open the panel still but it’s less convenient)

so i was wondering if you could add the bottom part of the popup when the button is greyed (disable and open whitelist) i think that would be nice[/quote]

Uhmm… it is meant to be that way. Do I need to explain the rationale behind the design??[/quote]

From the old support thread.


(blueskyy) #35

[quote=“molsten”]Hi Blueskyy,

I am using version 1.3.1 on FireFox 37.0.2 and when viewing YouTube it displays the V icon as it is supposed to, however I notice that the video playback bar pre-loads the video anyway. Is that intentional?[/quote]

From the old support thread.


(blueskyy) #36

[quote=“tingo”][quote=“molsten”]Hi Blueskyy,

I am using version 1.3.1 on FireFox 37.0.2 and when viewing YouTube it displays the V icon as it is supposed to, however I notice that the video playback bar pre-loads the video anyway. Is that intentional?[/quote]

Before blueskyy answers: I personally think it’s fine as it is, if that’s what allows me to download the videos with a video downloader extension (in order to watch them, say, in QuickTime)[/quote]

From the old support thread.


(blueskyy) #37

[quote=“blueskyy”][quote=“molsten”]Hi Blueskyy,

I am using version 1.3.1 on FireFox 37.0.2 and when viewing YouTube it displays the V icon as it is supposed to, however I notice that the video playback bar pre-loads the video anyway. Is that intentional?[/quote]

If the video icon is “V”, then it should NOT preload (video should stop loading, preloaded data discarded).

If the video icon changes from “V” to “V+”, then it should preload.

V+ means HTML5 videos that are controlled by html5 mediasource extension(s). A mediasouce extension can be many things, it can support encryption, it can support dynamic data loading, it can support streaming, etc, etc… In essence, there’s no elegant way of reestablishing a connection once you stop a V+ video from loading (I have already tested with Firefox 39 a few months back). Only those sites (youtube for example) that utilize and implement the mediasource extensions will have full playback control over its contents. And the only way a third party can gain access to html5 mediasource extension elements in the case of youtube for example, is though the APIs provided by youtube.[/quote]

From the old support thread.


(blueskyy) #38

[quote=“BillyJoeJimBob”]blueskyy: I’ve got an issue with flash control and a few NBC-Universal sites. Syfy.com will not run any video if flash control is set to allow the site, it must be completely disabled. Also, on NBC.com and usanetwork.com, the sites’ video will not play with flashcontrol set to allow, without further steps.

(This is using firefox 38.0.1; OSX 10.10.3.)

Thank you for a very useful add-on.[/quote]

From the old support thread.


(blueskyy) #39

[quote=“blueskyy”][quote=“BillyJoeJimBob”]I’ve got an issue with flash control and a few NBC-Universal sites. Syfy.com will not run any video if flash control is set to allow the site, it must be completely disabled. Also, on NBC.com and usanetwork.com, the sites’ video will not play with flash control set to allow, without further steps.
[/quote]

From my tests, Flash Control’s “click and play” does work on nbc.com and usanetwork.com; it doesn’t work though on syfy.com. To add them to the whitelist:

for “usanetwork.com” add "player.theplatform.com"
for “nbc.com” add "player.theplatform.com"
for “syfy.com” add BOTH “www.syfy.com” and “player.theplatform.com

Typically, when we want to add a domain to the whitelist, we right-click on the “play” icon, and select “allow xyz.domain.com” from the context menu.

As you can see (as you had mentioned also somewhat), the flash player used by NBC and its affiliates all resides in the same location: “player.theplatform.com”.[/quote]

From the old support thread.


(blueskyy) #40

[quote=“BillyJoeJimBob”][quote=“blueskyy”][quote=“BillyJoeJimBob”]I’ve got an issue with flash control and a few NBC-Universal sites. Syfy.com will not run any video if flash control is set to allow the site, it must be completely disabled. Also, on NBC.com and usanetwork.com, the sites’ video will not play with flash control set to allow, without further steps.
[/quote]

From my tests, Flash Control’s “click and play” does work on nbc.com and usanetwork.com; it doesn’t work though on syfy.com. To add them to the whitelist:

for “usanetwork.com” add "player.theplatform.com"
for “nbc.com” add "player.theplatform.com"
for “syfy.com” add BOTH “www.syfy.com” and “player.theplatform.com

Typically, when we want to add a domain to the whitelist, we right-click on the “play” icon, and select “allow xyz.domain.com” from the context menu.

As you can see (as you had mentioned also somewhat), the flash player used by NBC and its affiliates all resides in the same location: “player.theplatform.com”.[/quote]
Blueskyy: Thank you, that solved the issue. Also, Firefox’s built-in tracking blocker had to be whitelisted.[/quote]

From the old support thread.