[Support] Flash Control


(blueskyy) #1

Support and feedback thread for Flash Control.

https://addons.mozilla.org/en-us/firefox/addon/flash-control/

It gives you control over which sites are allowed to display the Flash player or the HTML5 player. Flash player plays Flash media (embed/object elements). HTML5 player plays HTML5 media (video/audio elements). It was originally designed with Youtube in mind.

In addition to the context menu for whitelisting domains, there’s also a simple UI, which is accessible via the Sidebar for managing the whitelist.


Flash control blocks this site
(blueskyy) #2

From the old support thread.


(blueskyy) #3

Yeah, we do get updates on review edits. I’ve done a quick test on:

http://www.itma.vt.edu/tech/shockwave.htm http://www.adobe.com/software/flash/about/

As before, I couldn’t duplicate the problems. As for this website:

http://hpr.dogphilosophy.net/test/

You should probably have given me the direct URL instead:

http://hpr.dogphilosophy.net/test/weba.weba

It’s immediately obvious to me why it’s shown as “V” and not “A” (my findings collaborates that as well). I hope you’re a programmer, if you’re, it would be pretty obvious to you as well. If not, stay with me, the explanation is quite simple…

When a user requested a file, Firefox handles it in two ways: either display it on the browser, or allow the user to download the file. When it displays a file on the browser and it is a text file (text based file, including html, xml, txt, etc), it renders the file directly. If it’s a media file, for example “weba.weba”, it will “embed” the media file into a HTML document template so that it could be displayed nicely in the browser. In this case, Firefox treats “weba.weba” as a video. This is NOT a bug with Firefox, because under the hood, audio and video elements are controlled by the same playback engine. If there’s video, it plays the video; if not, it just plays the audio, just like any desktop media player would.

HOWEVER, while testing it (http://hpr.dogphilosophy.net/test/weba.weba), I noticed the delay you spoke of. Yeah, it’s one or two seconds. I’ll look into that when I have the time. I’m always appreciative of good information.[/quote]

From the old support thread.


(blueskyy) #4

[quote=“Mizee”]Since one week the “flash control”-icon does not appear at youtube anymore. So the video will start without my permission.

(PS: I am new in this kink of forum stuff…so i dont know how to upload a screenshot of my settings.)[/quote]

From the old support thread.


(blueskyy) #5

[quote=“blueskyy”][quote=“Mizee”]Since one week the “flash control”-icon does not appear at youtube anymore. So the video will start without my permission.

(PS: I am new in this kink of forum stuff…so i dont know how to upload a screenshot of my settings.)[/quote]

What version of Firefox and Flash Control are you running?[/quote]

From the old support thread.


(blueskyy) #6

From the old support thread.


(blueskyy) #7

[quote=“tingo”]

Well, excuse me, but that’s exactly what I wrote: v.1.2.8. However, as I don’t know when the version update took place…

Yes, changes red when clicked, as it always has. Doesn’t make a difference, though.

'Twas the round red “f” icon. On YouTube don’t remember seeing the orange “v” shield-like, but I may be wrong.

From the old support thread.


(blueskyy) #8

[quote=“blueskyy”][quote=“tingo”]
Well, excuse me, but that’s exactly what I wrote: v.1.2.8. However, as I don’t know when the version update took place…

Yes, changes red when clicked, as it always has. Doesn’t make a difference, though.

'Twas the round red “f” icon. On YouTube don’t remember seeing the orange “v” shield-like, but I may be wrong.

No, I didn’t, I don’t really have the time at hand right now for this. But the other user on this thread says he did, to no avail.[/quote]

Sigh… sure, I was addressing you, but that (the whole paragraph) wasn’t directly only at you specifically. That was my response after reading through Mizee and your bug report.

I’m asking you to keep the icon green; you’re telling me you’ve been testing it by making it red… I don’t want you to be making it red, red means you’re allowing “Flash” on youtube… Why would I want you to do that…

You don’t have to test Flash Control for me, you’re not obliged to do that, although doing that would greatly narrow down the problem if there’s any… sigh… btw, the other user, johnff, his issue was different than yours… Both issues raised by him were already addressed. One has NOTHING to do with the Flash Control, the other wasn’t caused directly by Flash Control either, although I did find a minor optimization bug while looking through the code. v1.2.8 was to address his issues more or less. You can find the details in the changelog.[/quote]

From the old support thread.


(blueskyy) #9

[quote=“Mizee”][quote=“blueskyy”][quote=“Mizee”]Since one week the “flash control”-icon does not appear at youtube anymore. So the video will start without my permission.

(PS: I am new in this kink of forum stuff…so i dont know how to upload a screenshot of my settings.)[/quote]

What version of Firefox and Flash Control are you running?[/quote]

Flash Control 1.2.8
Firefox 25.0.1
I saw the orange V in the end, i think. But i am not realy sure about that.
The icon was and is green.

Do you know if its possible to upload a screenshot here, that might be a better then my bad english?

Oh…i try to start without the other extensions, now its working again, even after reactiving them. (Adblock plus and NoScript)
Ok…sorry for bothering you and that you for the fast support :)[/quote]

From the old support thread.


(blueskyy) #10

[quote=“tingo”][quote=“blueskyy”][quote=“tingo”]

[quote]Well, excuse me, but that’s exactly what I wrote: v.1.2.8. However, as I don’t know when the version update took place…
Yes, changes red when clicked, as it always has. Doesn’t make a difference, though.
'Twas the round red “f” icon. On YouTube don’t remember seeing the orange “v” shield-like, but I may be wrong.
No, I didn’t, I don’t really have the time at hand right now for this. But the other user on this thread says he did, to no avail.[/quote]
Sigh… sure, I was addressing you, but that (the whole paragraph) wasn’t directly only at you specifically. That was my response after reading through Mizee and your bug report.

I’m asking you to keep the icon green; you’re telling me you’ve been testing it by making it red… I don’t want you to be making it red, red means you’re allowing “Flash” on youtube… Why would I want you to do that…

You don’t have to test Flash Control for me, you’re not obliged to do that, although doing that would greatly narrow down the problem if there’s any… sigh… btw, the other user, johnff, his issue was different than yours… Both issues raised by him were already addressed. One has NOTHING to do with the Flash Control, the other wasn’t caused directly by Flash Control either, although I did find a minor optimization bug while looking through the code. v1.2.8 was to address his issues more or less. You can find the details in the changelog.[/quote][/quote]
I should maybe have written “tested once back and forth”. It’s back to green, was already back to green when I posted here.

I landed here after following the URL in your FAQ. Seemed like it was a general thread related to your extension, saw that Mizee had the same problem I had. I realize that johnff’s issues were different.

Lucky Mizee. One thing that does get updated rather frequently is the Flash Video Downloader - YouTube HD Download extension. I’m now trying to disable it, will let you know tomorrow if it made a difference.[/quote]

From the old support thread.


(blueskyy) #11

[quote=“blueskyy”][quote=“Mizee”]
Do you know if its possible to upload a screenshot here, that might be a better then my bad english?
[/quote]

No, I don’t think it’s possible. You can upload it elsewhere though, then link the image here, like I did in the main post (I use “imgur.com”).[/quote]

From the old support thread.


(blueskyy) #12

From the old support thread.


(blueskyy) #13

Is your Flash Control sidebar settings like this:

There’s already a new version out yesterday – v1.2.9. I would suggest that you update to that version as well. Although that not a bug-fix release (I added new features to it), at least we would have a common denominator. I’m be releasing yet another version tomorrow, again not bug-fix release, but a UI improvement release. You could alternatively wait until then to update, your choice. We’ll deal with your problem after that, okay?[/quote]

From the old support thread.


(blueskyy) #14

[quote=“tingo”]OK, thanks, that’s where the problem appears to be. It took me a while to find where the Flash Control sidebar was (I’ve beeen using All-in-One Sidebar for ages, so I’d forgotten that there was a sidebar menu). None of the ckeckboxes were checked. Don’t ask me why, I never have been there before.

What’s worse, though, is that they don’t stay checked: as soon as I quit the sidebar (F4 in AiO) and reopen it, the boxes are unchecked again. Qutting/relaunching Fx didn’t help.

Is there a workaround, such as editing something in about:config or elsewhere?[/quote]

From the old support thread.


(blueskyy) #15

[quote=“blueskyy”][quote=“tingo”]
Is there a workaround, such as editing something in about:config or elsewhere?[/quote]

No, there’s no workaround, storing Flash Control configurations inside about:config won’t change anything since AIOS would still display the same. It has nothing to do with Flash Control because at this point, you’ve given the control to AIOS to manage all the sidebars and panels and such. While Flash Control can guarantee that it won’t interfere with other extensions, we cannot say the same for other extensions.

Although AIOS has disabled Flash Control’s sidebar to a certain degree, it shouldn’t in theory affect Flash Control core functionality, Flash Control should still work if you’ve kept to the initial default settings. I’d like to see your Flash Control sidebar settings with AIOS disabled if that is possible. If it is AIOS interferring with Flash Control’s UI, then there’s nothing to fix in this regards.[/quote]

From the old support thread.


(blueskyy) #16

[quote=“ll25255252”]Can you please look at this page :
http://www.wimp.com/reactiondigital/
As of now (ver. 1.3.0) I need to “Disable Flash Control” so that video can be played. Why? because “allow http://www.wimp.com” doesn’t help (video won’t play).
Other than this site the addon works fine for me.
TIA.[/quote]

From the old support thread.


(blueskyy) #17

[quote=“blueskyy”][quote=“ll25255252”]Can you please look at this page :


As of now (ver. 1.3.0) I need to “Disable Flash Control” so that video can be played. Why? because “allow http://www.wimp.com” doesn’t help (video won’t play).
Other than this site the addon works fine for me.
TIA.[/quote]

Because the video is loaded from youtube, NOT wimp.com. If you add “www.youtube.com” to the whitelist, it will play automatically. Technically speaking, that isn’t a bug with Flash Control (because it is supposed to work that way) but a design “flaw” because I didn’t foresee that legit sites would overlay their own controls and player UI on top of youtube’s videos. I would get around to implementing new bits of code to counteract that problem if I can find the time, but for now, and probably the next few months, it would stay that way. The only option right now, as you’ve said, is to disable and enable it from the toolbar, or to add “www.youtube.com” into the whitelist (which is not the most ideal of solutions).[/quote]

From the old support thread.


(blueskyy) #18

[quote=“tingo”][quote=“blueskyy”][quote=“tingo”]
Is there a workaround, such as editing something in about:config or elsewhere?[/quote]

No, there’s no workaround, storing Flash Control configurations inside about:config won’t change anything since AIOS would still display the same. It has nothing to do with Flash Control because at this point, you’ve given the control to AIOS to manage all the sidebars and panels and such. While Flash Control can guarantee that it won’t interfere with other extensions, we cannot say the same for other extensions.

Although AIOS has disabled Flash Control’s sidebar to a certain degree, it shouldn’t in theory affect Flash Control core functionality, Flash Control should still work if you’ve kept to the initial default settings. I’d like to see your Flash Control sidebar settings with AIOS disabled if that is possible. If it is AIOS interferring with Flash Control’s UI, then there’s nothing to fix in this regards.[/quote]

Thanks, I was awaiting your reply until now, curious that I didn’t get the usual mail. Anyhow, I have just uninstalled Flash Control, quit Firefox, relaunched it, re-installed your extension (1.3.0): no difference. Actually, even with the sidebar open and the boxes checked, YouTube starts as if Flash Control wasn’t there.

I’ll try to disable AIOS when I have a minute and get back to you — although I can’t really see what might have changed about AIOS (current version appears to be from September).[/quote]

From the old support thread.


(blueskyy) #19

[quote=“blueskyy”][quote=“tingo”]
Thanks, I was awaiting your reply until now, curious that I didn’t get the usual mail. Anyhow, I have just uninstalled Flash Control, quit Firefox, relaunched it, re-installed your extension (1.3.0): no difference. [/quote]

That’s because Flash Control doesn’t remove users settings upon uninstall. But you’re absolutely on point there, the right behavior is probably to remove users settings as well. If it is possible to implement, ie, a way to distinguish between upgrades and reinstalls programmatically, I’ll try to get that component fixed in the next release.

The only “live” checkbox in the sidebar is “Disable Flash Control” checkbox. “Live” means it takes effect immediately. The rest of the settings requires foremost that “Disable Flash Control” is not “on”, and secondly, a manual page reload.

ps: Just between you and me, I didn’t test further with AIOS because I noticed unusual CPU usage when running it in Firefox Developer Edition. I was concerned that it might make certain changes permanent, and I didn’t want to risk having to re-install Firefox Developer Edition on my own testing platform which was already set up nicely to my liking.[/quote]

From the old support thread.


(blueskyy) #20

[quote=“tingo”][quote=“blueskyy”][quote=“tingo”]
Thanks, I was awaiting your reply until now, curious that I didn’t get the usual mail. Anyhow, I have just uninstalled Flash Control, quit Firefox, relaunched it, re-installed your extension (1.3.0): no difference. [/quote]

That’s because Flash Control doesn’t remove users settings upon uninstall. But you’re absolutely on point there, the right behavior is probably to remove users settings as well. If it is possible to implement, ie, a way to distinguish between upgrades and reinstalls programmatically, I’ll try to get that component fixed in the next release. [/quote]
Can I remove something manually — say in the Profile/xxxx.default/extensions directory? Actually, things have become more troublesome, see below…

OK, got it.

Between you and me [ :wink: ], I haven’t noticed any issue of the kind with AIOS. Could be a version thing, I haven’t upgraded to Fx 36 yet. And yes, “already set up nicely to my liking” is a reason why one can be reluctant to go ahead happily testing.

OK, now I’ve disabled the extensions Download YouTube Videos as MP4, FlashGot and AiOS. The first two made no difference, but with AiOS disabled I got what I guess is your full settings panel back, i.e. not with an empty whitelist and with those two boxes checked:

http://www.casimages.com/i/150225113357283725.jpg
(tried to insert that screen shot, but I can’t figure out how this [img] tag works).

But… it still made no difference: not a sign of your icon, YouTube videos start without being asked. And now there is a further problem, after I reactivated AiOS: once I open your Flash Control panel, it won’t let me close the sidebar again, either using the x, F4 (default in AiOS), or hovering out of it (custom setting in AiOS). Moreover, if I open other items in the sidebar (say the History or the Bookmarks), when I try to quit these with one of the methods above, your panel comes back instead, stubbornly.

So right here and now, I had no other choice than to disable Flash Control. Very unfortunate, because I had been making good use of it. I hope you can figure all this out, don’t be afraid to ask (but I’m no programmer).[/quote]

From the old support thread.