[Support] iGoogle


(erosman) #1

Please post your support questions about iGoogle here.

Thank you


(Samuel Jun) #2

I would love to see support for multiprocess! I’m seeing that multiprocess is disabled using the Add-on Compatibility Reporter when I have iGoogle enabled. Thank you!


(erosman) #3

I will work on it for the next update


(Voodootool) #4

Not working on FF 52b1.


(erosman) #5

Thank you . I will check it.


(Voodootool) #6

Thanks for the fast response. To replicate the bug:

  1. Drop an local Image from outside into Firefox.
  2. Right click and “Search Google for this Image”.
    -> FF51: Upload starts and Google loads.
    -> FF52: Nothing happens.

While you are already coding, may i ask for an option to load results in a Background Tab?

Thanks.


(erosman) #7

Thank you.

It is already there …

https://addons.mozilla.org/en-US/firefox/addon/igoogle/
Holding the ‘Ctrl’ key (Win/Linux) or ‘Cmd’ (Mac) (v1.4) will open the search result tab in the background (v 1.3) (v1.2 used ‘shift’ key)


(Voodootool) #8

I mean as default (optional). But its okay, its not a feature i can not live without. It just would be the last little bit to make it a perfect addon :wink:


(erosman) #9

Updated the code for the changes in Firefox 52


(Voodootool) #10

FF54b1: Local image upload to google broken again.

Greetings.


(erosman) #11

They keep on changing things in Firefox. In fact, I have written the code to port the addon to WebExtension but WebExtension doesn’t have a local file API so I am waiting to see if they fix it or not.

I will find a fix for this issue and upload a new version.
Thank you for reporting it.

Update: It is fixed and updated


#12

v2.0 image upload broken (dataURI right click) with 54.0b5 x64
OS windows10 x64 home.

http://imgur.com/a/Gpy0w

not working sidebar same.


(erosman) #13

I tested v2.0 with FF54.0b6 and all functions were working fine.

The message says connection error which means connection was broken. That is an issue to do with the internet and not the addon.

Out of curiosity, how large was the image that you were trying to upload?
Upland a very large image can result in connection time-out.

I just tested with the same image (We’re building a better Internet — Mozilla) and it worked fine.


#14

i tested
Google>search text ‘firefox’ >movies tab>right click any thumbnails

v1.7 is working.


(erosman) #15

Do you have any other addon that is interfering with it?

v1.7 was not a web-extension and the request were send differently with different permission.

WebExtensions are different. Someone else had a similar issue relating to another addon.
User had “RequestPolicy Continued” which was blocking the post requests thus resulting in ‘Connection Error: undefined undefined’ message.


#16

idk…
my addon list : ublock origin, downloadthemall, Expire history by days, fire drag, firegestures, Lastpass, New Tab Override (browser.newtab.url replacement) , Swift Selection Search , Open Bookmarks in New Tab

just i tested clean profile with v2.0 but not working same.
I’m waiting 54b6 update thanks.


(erosman) #17

Do you get any errors in the console?


#18

search word ‘firefox’ Browser Console from

Cross-Origin Request Blocked: The Same Origin Policy disallows reading the remote resource at https://www.google.co.jp/search?tbs=sbi:AMhZZivKU2fXFs-pKOTk_1do4hKW9x3mvlkoDXwNxRw_11935HChtKSFbnpE1NVOIjV6cZLMx2wgj0TtiowauxteSwh1o0t7TWey13YE2aWOrXGeayQJ-Otn5RBcHyrv4U7Kzjtb1hC43T2N1FKoSHxjqlO30rNMqxjvk6YgJQqIcWut_1-k0wKzERw1fTT3WzISHZbNAXkJrmPVKbk469SyLbxkYGJZZYknS5u0M0XJmzRPAum3eIPPkpLaiZ7eQoSjedwPkWIAGCUfhieWQzNrANSYXoAFOT6ZZi1UZgdSeRUXOJpGi7FIhLe8N0hirMr8BhAsS5R20AdIJZxZ4ZEtzWrmm0Ta69hKzdGleaDauoh1gKFNsbqFvHPHd9aWfDNf8SHW7Yvuyi9rR7bcwUIH1EtPGQS9zxVuqumDfRyzkdE-OL_1vvNhL-pRlT7_1DAteWpLIv6gm7A8hcL5I1UL719cUey3ui9ihBIdZjHk9uOBvuEs-ccd0YK-za2tJrGPrcjXosYVHdHZs4iyEdVPSc9wvHwR8w1_1RjjX0BJgPySklsAIjvQ8zSWBV-1ETzFKtmTPzNei5dpixL1SDhcOAEb5P_17GwUZBjYSPNbLo7ug-xGVMC2o07T5I5VMBuRPyHSihddS_1taHekVqOSjWT7nScSSKR7HZG0tFCuXVpdLAiUOVs6l9BnyiZVuoDkO8BDgH_1OnR6p9dGevoKDIaShOaH5G5dfBEMOP68RRGQSU7f6KaQ4GS9hxSrE0QIfzU-4MgKeEk3HGMHnbYORd0rveNHf-cK8UyPPH8tMI0uCiv6Jg4QiiAsPpHCPd9Q19dao-rg3ZomCMo5NpZnfJ-JCdNnxbtmG3WtIR1uLe-SGy6ebfxuOToJkii3OiiFmM2pCZRmFr-XbX-guBaDjQoGugk5C4YtYQX-Lrx7MscAd-u_1DnmVHBjmx_1mnfBY0LtPPSw-QkBoV1Qnj8RGFwyDaVRyNiC3Lnpt5_1IukQ9Lootdz-hHUWLHedZLDSKKCrtJecAPPpPKN8c-u3z06DV23UnI99PD6PkSEZOfZz7-fIxE4XGGj6MxghgGmaE1_1yWV949BAANFh779J6id5oHM1Px8-8FvidR2MDqGV-ldC2McmmPr64rdbrgBzCMICZB59tfjAhfPb7jEf2iHr_1XZpjAHeBTj0QIP6jD6tWhazllWm43tOSGQlsPQbdryowrL3_1_1Vsgh89mcx0XgLxWgc26YO-6vRXJbvcJn2wKhIcoRY_17_1I0F16owK9yqj_1trO-D9HnXq_1za3E6BemjS3M0l6L53uaZeIOPECfZ8mGpIQu4wz2Kwn27Z_1uezJyq7zD3QPjMVlyCFELlbXW-sEI6BZzyQPycFgr6eVxMo8NXSrgvEUFWuigcclgijFdmzbvC_1HClbCzXsYNveXzey-QsO6DNnb7g6XPj3DCMkybdKXPecrT5uPzuotP2UzuBr9t6kRP0XUAfGEwr1OUxNjlVEP8by5XK7TD3q_1cmA_1GaZoQABPKpQuxmahg-sVAa2Cr7tzJqpsbbfIn9fa5GnHytZ6oDSuCYsNqLV98_144q-RI00IURozF8Ps2cemraqNVsexGVUXQwWJKdEtfwNuEZrjws9Mh7TyMpTMwmwj7qWrVsjuzEdRaqlMu4OAr9DKn1IoQg_18zF1ANLB3v&gws_rd=cr&ei=YecOWeHcCci98QW-gKPYBA. (Reason: CORS header ‘Access-Control-Allow-Origin’ missing). 1 (unknown)


(erosman) #19

Now I see…

Addon sends the request to www.google.com
Either Google of your browser or another addon, redirects www.google.com to www.google.co.jp

www.google.co.jp has not been given the permission by the addon, therefore the connection gets blocked.

Let me sort out a fix and I will post an update.

Thank you for letting me know.


(erosman) #20

@Userfx v2.1 is online. Check and let me know how it works.