Tabs in two or more Rows (like TabMixPro) in Quantum?


(Tony) #21

Just applied your version and it works like a charm…only had to changed the Tabs Margin Left to 1 to suit my liking!
Thanks for the share.


(Deyx9999) #22

My decision was to stick with 56v to keep all my addons. The missing multirow just turned me off. Disabled all updates and its still working.
You can also use the long term service version https://www.mozilla.org/en-US/firefox/organizations/all/


(Tom) #23

Amazing work! Finally I can again see I have all too many tabs open. Now we just need someone to make this work as an extension!


(Bob Bressler) #24

thanks fh1. Simple easy to follow, except I still have the standard 1 long row. Does this need to be enabled to work? Are there other add-ons that might be preventing it from working?


#25

Where to download updated version?


How to modify appearance of tabs themselves with WebExtension?
#26

What would be fun now is a way to navigate via keyboard vertically through the tab rows. You use ctl pgup and ctl pgdn to move right and left. So how about ctrl home/end to go down one plus over one left/right and wrap top from the bottom, and ctrl insert/delete to go up one plus left or right one wrap bottom from the first line? I know, off topic here, but we don’t get the family together that often. :slight_smile:

With alcohol you get all the confidence and none of the competence.


#28

Thanks, this is very useful.

Only thing is, the tabs are to narrow for me. I tried to change
.tabbrowser-tab:not([pinned]) {min-width:35px;max-width:35px;}
to
.tabbrowser-tab:not([pinned]) {min-width:35px;max-width:70px;}, but it didn’t seem to work for me. Could you give me any pointers?

Also, the native functionality that starts with wide tabs and shrinks them if they start to be many is cool. Would there be a way to keep this while having several tabs, when the native display starts to use some scrolling? That’s a pity that Mozilla doesn’t offer an option to switch to multilines instead of scrolling.


(Mina Mikhail) #29

To increase tabs width modify “browser.tabs.tabMinWidth” in about:config


#31

If you find it does not work, make sure that your chrome folder is inside the folder which opens when clicking the ‘Open Folder’ button in step 2 of instructions I gave above. Some addons or operating systems may move this folder elsewhere it seems.

As for the small tab width, try setting min-width to 70 as well, that way all tabs are bigger “as a minimum”. But note that I previously found (an older) version of FF to work faster if the tab width is really small.


#32

it is possible to limit the rows?