Temporary Add-ons won't load: XULStore.jsm "Error: Can't find profile directory"

The title pretty much says it all: I cannot load temporary addons anymore. They show up on the “about:debugging” page after I try to load them, but do not show any signs of running. The “Inspect” button shows an error “Can’t find profile directory” with the filename XULStore.jsm.

I’ve tried creating deleting (renaming) XULStore.jsm, restarting Firefox, creating a new profile, and rebooting the computer. Still having the issue.

One thing that may be related is that I was working on a very memory intensive addon (it attempted to load 300+ multi-megabyte images) when this started. However, it is not just this addon that I cannot temporarily load; others that worked before will not load as temporary addons.

Any help would be welcome. :slight_smile:

1 Like

How to solve this problem? anyone has idea?

I suggest you file a bug for it.

Same issue here.
I found a bugreport in bugzilla saying this bug won’t be fixed because it shouldn’t happen for long … It’s been 10 monthts now :frowning: