Testing Nightly multiprocess content


(Rubén Martín) #1

Today’s Nightly update (v54) comes with a nice feature: Two processes for web content.

Until now multi-process Firefox had just two processes, one for web content and one for the user interface. Today nightly enables multiple processes for content (two for now) and the idea is to increase this default number over time.

Here you have the bug about this change.

So I went bananas and since I saw it was working well I forced from about:config to use 10 processes instead of the default 2 (because why not?). The pref to change:

dom.ipc.processCount

As expected the RAM usage is higher now (but still ok). Having a i7 machine the performance increase has been really big.

Note: Some users are not getting multi-process due incompatible add-ons, you can force it (at your own risk) by setting:

browser.tabs.remote.autostart a True
browser.tabs.remote.force-enable a True

Are you also playing with this feature? How is it working?


(Leo McArdle) #2

Having multiple Discourse instances open during development often leads to awful slowdowns for me. Let’s see if (and hope that!) more processes will reduce that.

I’ve got the memory to spare…


(Michael Kohler) #3

I’ve done that quite some time ago already, works pretty well, though my poor 4 GB RAM laptop suffers a little bit from time to time. I’ve had 2 set so far, let’s try with 4 now :slight_smile: #LivingOnTheEdge

So far my experience has been good, hope we can get this right and improve our performance with it.


(Rubén Martín) #4

Day 2 with 10 processes: No crashes or errors, performance seems to be way better.

Edit: Going to 20 today.


(Michael Kohler) #5

Since that worked good, I’ve gone up to 20. RAM usage seems to be about the same. I’ll report back :slight_smile:


(Lorenzo Kappeler) #6

I have set it to 100 for the last two days, so far no problems. The memory usage seems to be about same as usual. Switching tabs feels much smoother, it seems the content is rendered faster when I have a lot of tabs open.

Today I recognized some lag while dragging out a tab into a new window. (This could also had come from my virus scanner or docker deamon…)

There is also the flag dom.ipc.processCount.webLargeAllocation, does someone know what it does.
(More exactly than suggesting it form it’s name)


(Rubén Martín) #7

Reading around, this is what I see about the right number of processes:

Generally you will actually get a performance loss at some point if you keep increasing the process number because managing them gets more costly. If you cross the number of threads your CPU has you will most likely lose performance. Also chances are it will drain more power.

At the same time it’s also true not all sites are active in the background and we want to also isolate each site so it doesn’t affect others performance.


(Spike) #8

Thank you for the nudge to use Nightly again- currently running with 10 processes and it seems loads faster even if it is using 8GBof my 16GB RAM :slight_smile:


(Gabriela) #9

I set the pref to 10 as soon as it was possible. It works fine, no memory issues.