Thunderbird Beta "Not responding" and freezes on Windows [caused by Windows Defender]

Version 60.0b11
For quite some time now, Thunderbird freezes any time, any place when I click on it. It stays like this from 5 seconds to 1 minute, then return to normal. I’m on Windows 10 Pro.
One thing I noticed in the message bar on the bottom is: “downloading message 1 from 4000 into All mail”.
But it has been long time that all my emails are in the inbox.
Any idea somebody?

Someone is actively working on imap issues, so this might be fixed in 63.0b1 which is just out. If you find it isn’t fixed please post your findings here. Note, you may find add-ons not working in 63 - check the release notes.

Thanks, I’ll wait then for the 63 release.

I’m now on version 64.0b1 32 bits, I’m on a dell Laptop Inspiron 17, 5000 series and I still have problems with freezing when touching something in Thunderbird. It’s not all the time but it happens 10 to 20 times a day.
Also, I’ve been on the beta version for 2 years now, but never did we have a signature add-on working on the beta version. Every single add on is “Not compatible with this version of TB”.
If I revert to the regular version, will I loose all my emails, folders etc? Is it complicated to do? Either I go back to the regular version or I will change program, the beta is full of the same bugs for the last years and many of the basic functionalities are not working properly.
Thanks

a) Which add-ons can you not live without?
b) regarding your performance issues, have you gone through https://wiki.mozilla.org/Thunderbird:Testing:Memory_Usage_Problems ?

I’m having the same issues for the last couple of months and with the last couple of versions. Thunderbid continuesly keeps freezing / stops responding. Currently on version 60.4.0 on Linux Mint. Sometimes it freezes for just a couple of second and sometimes more than a minute. Tried to turn off all add-ons but it wont help. If anyone knows how to fix this please let me know what to do. Thank you!

Hi, In my case it is the “Anti malware service executable” from Windows Defender. Every time TB freezes, I went to the task manager and the service is scanning and as soon as the service stop scanning, TB get back the hand. Hope it helps

Thnx 4 the advice @mmilic but i’m using TB on Linux mint.

@Joris linux seems to have some unique issues https://mzl.la/2G4LG75

My thunderbird on Mac keeps hanging, usually when I press send. I have to close and open new each time. About 6 times a day. Any suggestions?
I am using 60.7.2 on OS X El Capitan iMac

Did you ever get this solved? TB is also just stopping on my mac at least once a day. I have TB 60.8.0 and a new Mac Mini running 10.14.5. I thought the problem was from my 2012 Mac mini being out of gas but the problem persists.

It is annoying.

Thanks for any advice you have.

I get a “wheel of death” and when I check the force quit pull down, the note is “Not Responding” so I have to force quit TB. Then log back in. It just happened again and happened at the time I was sending an email.

Hi, sorry for the mac users, I do not have any advice. As for me, I added all TB folder in the exceptions in Windows Defender. I know this is really not the best solution as you may have attachments with viruses, but I couldn’t work otherwise. Had spend many hours on it anyway.

I have the same issue on multiple machines, Linux and Mac. The freeze occurs on change of focus, when I click into the Thundebird window or click into the window created with New Message. It frequently freezes typing a new message. On Mac I can get a spinning blue disc or a spinning rainbow disc.

1 Like

Frequent unresponsiveness here, too, for a long time. I just force quit/deal with it, usually, but figured I’d finally get around to adding my own experience. For me, it typically happens after I’ve minimized my Thunderbird inbox window to my Mac OS X dock, then go back to it later to read new emails. As soon as I click the minimized window to pull it out of the dock, I’ve got the spinning rainbow beach ball and have to force quit. It’s not every time, but frequent enough to be annoying. Pretty much at least once a day.

MacBook Pro (15-inch, 2018)
Mac OS X Mojave (10.14.5)
Thunderbird 60.8.0

Gentle users…

The original Windows users’ problem is resolved, and also Beta was being used.

If you are a Mac user, or not using Beta, please file a new topic for your problem. Also, check https://wiki.mozilla.org/Thunderbird:Testing:Memory_Usage_Problems