Uploading a new addon or updating the existing addon stucks at validating

I have published my addon on addons.mozilla, when i try to upload new version of the addon the progress bar stucks at validating filename.zip.

I have tried creating a new addon, still the progress bar stucks at validationg filenam.zip

Methods tried:

  1. Logging in again
  2. Clearing browser data and trying again
  3. Changing different browser and networks

Nothing seems to be working


I’m experiencing the same issue when uploading a new addon. I tried:

  1. Using the web-ext command line tool. It also gets stuck at validating
  2. Uploading an addon package which I know for certain has worked in the past.

This might be a server issue…


Could be but i have been trying for almost 2 days


Strange - I just tried uploading again and for some reason the addon now appears under “My Add-ons”, just without any versions. Trying to upload a version to it gets stuck at the same validation step

1 Like

Same issue here. Also for two days now. It worked briefly yesterday, but gets stuck again at the validating stage again today. It appears to be checking for updates, and I can see in the developer console’s Network tab that the responses point to a URL that has a status message “Error: Validation task could not complete or completed with errors”.


When i see my response tab the error object is null in my case but the request keeps on hitting and get stuck at validating


Same here. The error message I posted appears if I follow the URL in ‘full_report_url’ in that same JSON response.


yes it doesnot show what actually is the error


Same issue … i also tried with a new browser profile to make sure it wasent something settings related. And i got the same result.

In the network console there is a repeating request ( guess polling for completion status) , but the page never continuous to the next step.


Same thing here, please fix ASAP.


Same here, please fix it.


The same thing happens to me. That “full_report_url” page POSTs to a “standalone upload” URL which returns the same results as the page being polled on the original upload screen. (error is null)

This makes me think that the “Validation task could not complete or completed with errors” message is incorrect as they probably don’t expect us to be looking at that page before the validation is complete.


Same issue here since April 7, now rolling into April 8.

Last successful build for an update was April 6.

  • Validation completes, spins and eventually errors out stating the server could not be reached when using web-ext
  • Validation completes, spins and eventually errors out stating the server could not be reached when using the upload page

The only thing that stands out to me is the 302 at the beginning of the process, but HTTP 302 followed by expected HTTP 200 responses could be just fine for this service (I’ve never looked at status codes for the upload page before because I never had a reason to review them until now).

I really hope the right people see our posts. There is work we have to get done.


It looks like someone opened a GitHub issue for this:

I’ve commented with most of the details we established in this thread


Maybe they are not going to fix it in the weekend, are they?

1 Like

They should definitely fix this issue as this is creating a lot of trouble.


Looks like it’s good again based on the last response to the ticket. I’ve been able to get an add-on through again!

as of 2023/04/10 08:25am PDT, this is still not working

Also not working for me…

We’ve seen issues over the last few days and we attempted to mitigate those. Right now, everything should be working as usual. We are still trying to identify the root cause, though, so the problem might occur again.

Please see: https://github.com/mozilla/addons/issues/1481 for more information.