Voice uploads failing

Is anyone else experiencing this? I’m getting the message “Upload of this clip keeps failing at server, reload the page or try after sometime.”

(It’s worth mentioning that the error message’s advice to reload the page loses your recordings.)

I checked in the console and there are several CSP errors referring to the page’s security settings blocking inline scripts, which may be a hint as to the cause of the issue.

It’s been 8 hours since the day counter reset and only 10 recordings have been made in English, so it seems like this problem may not just be affecting me.

I’m have same problem “Upload of this clip keeps failing at server, reload the page or try after sometime.”

Thanks for flagging this issue! Can you let me know what browser you were on, and whether you were logged in?

@phirework I’m on Firefox 70.0.1 on Windows 10. I tried on Firefox (not sure of the exact version) on Ubuntu with the same result. I also get the same result with Chrome 78.

I am logged into my account. I tried logging out and recording clips as a guest and they still fail to upload.

If I check the Network tab, I can see that the POST request fails with status code 500 save_clip_error.

Same problem here, Windows 10 using both Chrome 78.0.3904.97 and Firefox 70.0.1 (64-bit).
I’m getting the following error on the console:
VM17:1 POST https://voice.mozilla.org/api/v1/es/clips 500 (save_clip_error)

I also see this error in Firefox and Chromium.
I got a “Content Security Policy: The page’s settings blocked the loading of a resource at inline (“script-src”).” in the console.

I dont see a 500 in the network tab tho…

We have pinged devs and IT to look into this asap.

1 Like

Same here. But the weird thing is that when I click “abort” it seems to upload one file and then shows the same message again. I managed to upload all five files this way, at least they were counted in the frontend.

Hey folks, we’re testing a fix for this problem on staging. It seems to be an intermittent issue that half of our team couldn’t reproduce at all, so it would be a great help if you could try submitting clips on our staging server and letting us know your result.


@phirework I have the same issue with the staging site. I’m happy to help debug this - let me know what info you need from me.

@dabinat Just to clarify - you’re still having the issue on staging site as of right now? We just pushed a fix, it’s possible you may also need to clear your browser cache.

@phirework I cleared cache and cookies and tried again with the same result.

@dabinat Okay that’s super helpful, thank you. Can you tell me where you’re located geographically? We’re seeing some weird distribution in who can and cannot reproduce the bug.

@phirework I’m in Los Angeles.

@dabinat Have you been unable to upload any clips since you reported this, or is it just some of the time?

@phirework It’s every single time. It’s never been successful for me.

“Upload of this clip keeps failing at server, reload the page or try after sometime”
It still seems to work after I click abort. At least it counts the numbers up. But when I look at the network traffic I only see a 500 “save_clip_error” against /api/v1/de/clips

I am using Firefox on OS X from Germany.

I tried using the staging server, but I got the same result, error 500, blank response from the server. I’m trying from Spain.
Also failing from Chrome:

@dabinat (and others) Well, the good news is, our db shows you as having uploaded 10 clips to production today and I’ve verified that those files have been saved in S3, so your efforts were not wasted! We’ve narrowed down where we think the problem is happening, could I get your help testing again on staging?