Voiceover reading the page non-stop

Hi, we found this issue during accessibility testing that voiceover keeps reading page non-stop if the page first loaded or reloaded.

How to duplicate this issue:

  1. turn on voiceover
  2. go to any page through Firefox (I’ve tried Youtube, Google, https://developer.mozilla.org/)
  3. Voiceover will keep reading each link non-stop until press ctrl key to pause or tab key to control.

Question:

  1. How to disable the non-stop reading when page first loaded or reloaded?

Browser: Firefox 83.0, Firefox 86.0
OS: macOS Mojave 10.14.6

Thank you so much!

Hi! I think this is related to a VoiceOver preference and not the browser – if you open VoiceOver Utiilty and navigate to Web > General, there’s a checkbox for “Automatically speak the webpage”. If you uncheck that, VO should respect that preference. Please let me know the issue persists!