AdBlock Plus will not install

Nothing is working; its not limited to AdBlock; this sucks!

1 Like

This situation is quite dire, however the team released an announcement saying they are working to fix it.

Here are some updates from the Mozilla Add-ons Twitter:

Thanks achernoch. Didn’t know the issues was widespread. Following Mozilla Add-ons.

If you can, pleae try this and see if it works:

Install ESR, developer, or nightly edition
open about:config
change xpinstall.signatures.required to "false"
you can now re enable all extensions

Worked for me, my version is the 67.0b16 (64-bit) Developer Edition.

Original post:

Good luck!

1 Like

Hi @fredw1604, We understand your problem. This has been caused by a certificate issue. Firefox Team is currently working on a fix and will be providing updates on this thread: Certificate issue causing add-ons to be disabled or fail to install.

Most everything gets the same download error message. It’s not just adblock, which has been a staple for years. Try some others and see what happens.

There will be a lot of somewhat knowledgeable folks that just go with the developer edition…to HECK with the brains at the helm who have the addon adblock disabled. Fools have disabled the best addon they have.

It feels so sad to know that this issue is still not fixed… :mask::mask::mask::mask:

Nothing will install. I got the same error message for six different addons. Good ol’ Firefox wiped out all but one of my existing addons, and won’t let me install ANYTHING to replace them. Just great. Damn ads all over the screen everywhere I go.


That Mozilla is concerned about unverified addons is fine. But just notify the users; do NOT delete them! Users should be permitted to make that decision themselves. After all, it’s the users’ machines – not Mozilla’s.

Don’t be my nanny. I’m an adult, have been for decades, and a computer jock. Your behavior in such instances is insulting – even when there are no bugs in your code.

You have another day to fix this – I’ll be away for a day. If no fix: I’m dumping all my bookmarks, installing them in Chrome.

Shame on you.

1 Like

yeah the deletion or disabling of previously added addons is bs, now if i watch youtube for instance i gotta deal with friggin ads stopping play back every few minutes (like its friggin hulu), having to rebuffer every 2-3 minutes is friggin annoying as hell, i use firefox for streaming videos (works better then chrome imo) i only use chrome for downloads since firefox has a file size limit of like 1.2 gb, so no 10-20 gb game downloads thru firefox, lol, may want to look into fixing the download limit thing, if i download thru mega it wants you to download the desktop app…um no thanks dont need it, ill just use a browser without the limit thanks, lol

but yeah addons are the sole premise of the user and not the company that makes the browser, we are adding the addons not mozilla, but the failed downloads display these messages, adblock plus from their site, it says the file is corrupted…what…and as for downloads from mozilla itself it says download failed please check connection…huh, but i have an internet connection how else did i get onto the site? makes no sense to me honestly

the only addon i got to work was webrtc as a test download to find one that would actually download (i only tested ones that i would actually use, and out of a dozen or so tests this was the only one that worked, neither adblock plus nor the mozilla adblock would download)

but been over a day since this occured and still isnt fixed…i didnt suffer from it till a few hrs ago and i was online earlier in the day, then all of a sudden my addons were no longer viable, pissed me off

Yeah this sucks right now i use adblock a lot on firefox i just notice that it was gone and started to get ad’s to pop up hope they fix it quick.

still down. I thought it was my OZ NBN connection so called up and got them to do a hard reset of my internet. I doubled my connection speed fixing the bug in the WiFI but came back online to reload the add-ons and it’s still broken after two days. please fix it… i can’t use any website with no add blockers or antivirus

This issue is never getting fixed. Initially they said it’s going to take few hours, they already had a fix for it and whatnot… and now it’s ben almost a day. I’ve used Mozilla for close to a decade now but this makes me look for a substitute. I’m not going to use browser that prohibits the use of ad blockers and be forced to deal with all the nonsense this implies.

Why doesn’t Mozilla test these things before freeing them on the world?

well I guess I switching to chrome until this madness be fixed.

Mozilla is testing the fix a lot, which is why it’s still not here. SO yes, Mozilla tests “these things”, however you will always miss some things when testing, sadly.

I have been using mozilla for such a long time and i think this is how the journey ends. Hasta la vista !!! You will be remembered :’(

1 Like

I guess FIREFOX or someone really wanted us to see a few ads until they say that they have fixed the issue!! Unbelievable!

1 Like