Add-on buttons unavailable


I’ve installed the keepassxc add-on. According to the tutorial I need to click the button in the top right corner to configure it. It should be between the search bar and the library button. There aren’t any buttons there, neither for keepass nor for the other two add-ons I use. I remember there used to be buttons here of my add-ons in the past (it’s been a while though …)

I have tried:

  • customize --> restore default
  • restart firefox

Firefox version 74 on ubuntu 18

I would appreciate if someone can help me find those buttons or an alternative way to configure the keepass add-on (link to the desktop application).

Any chance you are in a private browsing window (automatic private browsing)? Extensions need to be expressly enabled to run in private windows. If you click the extension title on the Add-ons page, Firefox should show a Details pane with a row to give that permission. You might also be able to display an Options panel there, although probably not the same one displayed by a toolbar button.

Hello jscher2000,

yes, that was it. By making firefox not remember search history I somehow ended up in automatic private browsing mode. Now, I can see the buttons and also access the preferences through the add-ons menu.

Thank you!