Addon in Incomplete state after trying to bump version


We tried to update the version of our addon but AMO asked me to change the slug and is now stated as “Incomplete” since we didn’t submit the form.

What we did:

  • Change owner of the addon
  • Update a new version (2.0) of the addon, but wrongly selected “unlisted” instead of publishing it on AMO
  • Bump version to 2.1 and trying to update a new version again with the “list on AMO” option

AMO redirected us on “Submit a new add-on” webpage, asking us to fill again informations about the addon and to select a new slug.

Is it possible to fix it ? We would like to just upload a new version of our existing addon and keep the actual slug.

The extension is Proutify.



When submitting a new version, did you go through the Developer Hub, then your add-on and selected Upload new version?

What you described, it sounds like you may have tried to submit a new add-on, in which case you can’t use the same slug as previous and that’s why the system was warning about it and asking for a different one. It’s also important to note that if a new add-on is submitted instead of a new version, existing users won’t get updated to the newest version.