Addons downloaded but no option to install

(Gene S) #1

Firefox 60.6.1 / Linux /
trying to install an addon. Not installing.
1st method: selected the addon “youtube_download_helper” from the addons.mozilla.org lists; clicked on “add to firefox”; I get the list of permissions and prompted to “cancel or add”; click on add. Message box goes away and “installing” icon blinks forever. Open addon manager and the addon shows “Downloaded”. I don’t see any option to Install. Tried left click, center click, right click, alt-left click, etc. No response to anything.
2nd method: used “tools for addons” and selected “install add-on from file”; selected the “youtube_download_helper-4.1-an+fx.xpi” file (in a Download folder fetched by previous “save link as…” action) ; then same sequence as above, i.e. accepted permissions with “add”; shows up in addon manager with “Downloaded” state but no Install option.
What am I missing?

(Martin Giger) #2

When an extension is listed in the add-on manager it is installed. You can enable/disable or uninstall extensions there.

(Gene S) #3

Hmmm. From the symptoms I’m seeing, I don’t think the install actually completed. For one thing, in add-ons manager, there is NO button for enable or disable or uninstall - just a blue box saying “DOWNLOADED”.
For a second thing, in add-ons manager, if I go to “plugins” I see options for preferences and activation but coming back to “extensions” there’s nothing like that. In fact it TIMES OUT… i.e. after about 4 or 5 minutes, switching to plugins and back to extensions the “Downloaded” extension is GONE.
– I am downloading Firefox 66.0.3 to see if that works any differently –
To me it has all the symptoms of missing file (write) permissions but I don’t know which of the firefox directories to check.
/edit/ Firefox 66.0.3 installed - same problem. Regarding “timeout”, it is not a time limit - anything producing a page refresh (eg. ctrl-R or switching to another browser tab and back) displays an add-ons manager page with “extensions” empty. /edit/

(Gene S) #4

An update… Now running 66.0.5, and was following the threads regarding add-ons and the suggested fixes and/or workarounds. Still no joy. An add-on extension “downloads” (at least that’s what the add-on status shows) but does nothing after that. It DOES NOT INSTALL. A temporary file appears in the /tmp directory, such as /tmp/tmp-74g.xpi, with proper read permissions. And possibly of diagnostic use - in Browser Console a message appears “Button click happened before the window was focused.” I don’t know how that can be, since the window manager moves focus wherever the mouse goes. And I see the “ADD” button change color when I’m about to click on it (to acknowledge the permissions caution message).
Meanwhile, the add-on in question CAN be installed via the “debug addons” facility although it is only temporary. (And it does work when installed this way.)

(jscher2000) #5

There’s a similar-sounding thread on Reddit with matching screenshot, but in that case, the update helped:

You could try hiding the extensions.json file and let Firefox generate a new one and see whether that helps. Open your current Firefox settings (AKA Firefox profile) folder using either

  • “3-bar” menu button > “?” Help > Troubleshooting Information
  • (menu bar) Help > Troubleshooting Information
  • type or paste about:support in the address bar and press Enter

In the first table on the page, on the Profile Folder row, click the “Open Directory” button. This should launch a new window listing various files and folders in your system’s file browser.

Leaving that window open, switch back to Firefox and Quit.

Pause while Firefox finishes its cleanup, then rename extensions.json to something like extensionsOLD.json.

Start Firefox back up again, and it should rebuild the file. You may get prompts on whether to enable or disable externally installed extensions. Any improvement with new installations?