Browser detection incorrect

I am on Windows 10. I do have some security settings set (these settings). Will not let me install an add-on even though I do have a valid Firefox version

There’s an issue open for that: https://github.com/mozilla/addons-frontend/issues/4910. In the meantime, the only workarounds are to download and install the XPI manually, or revert that pref change when you need to install something from AMO.

Ok, thanks @jorgev. Just to be clear for future searchers - this is the privacy.resistFingerprinting setting, correct?

Yes, that’s the pref causing the problems.