CalDAV Calendar disabled


(Ralf Wilke) #1

I am hosting several CalDAV calendars on my Synology NAS that I access with Lightning (and Android). This worked well until a few days ago, when the IP address of my NAS changed and required the reconfiguration of the CalDAV URLs.
Unfortunately, I do not get some of the calendars activated in Lightning on some some of my devices. The are greyed out and if I tick “Switch this Calendar on” it only takes one second and then it is gray again. The strange pattern is that not all my devices are affected by this, despite that I use exactly the same URL. And one of the Calendars is always “on” while the other two are only “on” on one Win7 laptop, while “off” on one Win10 laptop and a Win7 desktop. All my PCs should run the latest version of Thunderbird with integrated Lightning V.5.4.9.1. The NAS runs DSM 6.2.1-23824 Update 1. I do not have any issues with the Android device.

I would appreciate if there is any hint what I can do to get the calendars activated in Lightning.


(David Ross - Mozilla Rep & UK Community) #2

Shifted to the more appropriate Thunderbird/Add-ons channel.


(Ryan Sipes) #3

Simple question, but have you tried removing it and re-adding it to Thunderbird to see if that makes a difference? I’m using two CalDav accounts and haven’t seen any issues.


(Ralf Wilke) #4

Yes, I had to re-add them by creating new calendars anyway because
Lightning does not permit me to change the URL of an existing Calendar
(Although I would prefer to do this because it is much simpler. I can
only change the IP for existing addressbooks). I removed and re-added
the calendars multiple times because I had this issue previously (couple
of years ago) and can remember that it worked after a number of
attempts. But this time the issue was more persistent and that’s why I
posted it.

In the meantime I can confirm that it now works on another of my laptops
(just by waiting for a day without changing anything). And possibly when
I am back to the office on Monday it will also work on the final device.
It looks to me that there is some sort of bug but not sure what exactly.