Can't create leak sensor rule SmartThings

Hey all,

I bought a Smart Things leak sensor and the pairing with the zigbee add-on was simple. But I can’t create a rule to do anything when the status changes from Dry to Wet. Every other property of the Leak Sensor (or Custom thing, tried both) is available for rule creation, but not the only one I bought it for.

Anyone know why that is? How do others have leak sensors wired up?



@kgiori weren’t you just telling me the other day that there was something weird with this property as it relates to rules?

Do you have the latest model?

I have an older one (I think the 2016 version) and I’m able to set rules based on the leak on/off status so it could be a problem with how the Zigbee classifier detects the Zigbee clusters of the newer version.

What properties do you see in the detail and rules views?

Ahh, I see! I do have the latest version, I was thrown by “on” when the UI made me think I needed to react to “wet” and “dry.”

Just tested it with checking for “On” and it worked.

Thank you!