Can't install addons [57.0.2/x64][Solved]


(Towa Shina) #1

Hi.

I’ve updated my firefox to 57.0.2 from 55.0.3 today. And then I tried to update my addons at about:addons but I couldn’t do it because of an error. I googled and find pages like this. “https://support.mozilla.org/ja/kb/unable-install-add-ons-extensions-or-themes” But it didn’t help me. I couldn’t find why the error occured.

After that I refreshed my firefox, which is deleting all of my settings. And I went to “https://addons.mozilla.org/ja/firefox/addon/norton-safe-web/” to re-install addons, but I couldn’t do it because of a connection error. I also tried turning my norton firewall off, but it didn’t help me at all.

At this point I was seriously anxious. I uninstalled my firefox, restarted my pc, deleted all files in %appdata%/roaming/Mozilla, re-installed firefox 57.0.2. And without messing any configs, I again went to addons.mozilla.org, but I couldn’t install any single addon.

Then I find pages like this. “https://addons.mozilla.org/ja/firefox/addon/norton-safe-web/versions/” And I tried to force downloading but firefox blocked it because of SEC_ERROR_UNKNOWN_ISSUER.

And I now realized that nearly all of pictures are gone on pages in addons.mozilla.org, and it’s not because of adblockers.

Is this problem because of https mixed-up contents? Is this happnening only to me? Is there a solution that helps me?

Please help me.
Thanks to all.

p.s. I don’t speak English. Sorry for terrible sentences!


(Towa Shina) #2

I solved it. It was because of Norton ConnectSafe, which is a dns service.

I found a page “https://support.mozilla.org/ja/questions/1196487” and I deleted my dns settings on control panel. And I went to about:addons, successfully completed updating all of my addons.

I’m sorry troubling you all.
Thanks for reading.