Can't login to AMO because two factor authentication that I never used or enabled, and I'm no extension developer. How to disable it?

I don’t need this nonsense. I read that its automatically enabled for extension developers, which I’m not.

The only thing I ever done other than rate and comment is sign some extensions so I could use them in Firefox when it became a requirement years ago. Those were never addons that were published. So why am I harassed with this?

More importantly: How do I turn it off?

This makes you an extension developer.

1 Like

Um, no. Not in reality. I never developed or published anything. Nor am I planning to.

as you state you did sign some addons in the past, and if you’re signing any addons in AMO means you’re part of the Dev community as per se, because those addons based on tnc are addons that will be published by another channel/website that’s not AMO, and even you’re not publishing it, you already did sign. You need to see the FAQ of AMO for disabling 2FA

Hi @avada, what @freaktechnikand @benlimanto said are correct.

If you would prefer to run an unsigned extension, and thus side-stepping logging in to AMO, you can do so through Firefox Nightly or Developer Edition by toggling a preference. See for more information.

Do you have a link? I didn’t find anything, otherwise I wouldn’t be asking.

Thanks, but I’m aware of it. (I used amo to sign extensions years ago.)
My problem is that I can’t use AMO now, because I can’t log in.

Sorry, you’ll need to enable 2FA to log in to AMO. There is no workaround.

I disable 2FA via , There’re sub section named Security and there is 2FA, but you need to turn on 2FA first then deactivate it.

It’s simple google search(ehem, DDG Search, DUCK IT), well you will get those support link. I use IAM for login in to AMO