Firefox cannot do sound in RDP connections


#1

Apparently, there is a huge issue related to the absence of sound in FF when using a Remote Desktop Connection (RDP), as explained here:

https://support.mozilla.org/en-US/kb/i-cant-play-audio-remote-desktop-connection1

I too have this problem. It arose initially when I upgraded 64-bit FF version 54, and it has remained ever since. I am now using FF Quantum’s latest version on 64-bit Windows 10, and the problem persists. There
is absolutely no sound coming from a web page in FF.

I have tried it with “all add-ons disabled” in Safe Mode, although I use one a few addons, but there were no change regardless. I am not inclined to “reduce the sandbox security level” as a remedy because it would
defeat the purpose of using Firefox as a defensive tool.

One more point I should mention, which seems relevant to this issue. I am running the Windows 10 system as a virtual machine in Hyper-V on Windows Server. It is my understanding that such VMs connect to Hyper-V
as if through a Remote Desktop Connection. When I mouse over Windows “Volume Mixer” application in the task bar, I see a popup showing it to be a “Remote Audio -100%”. Even so, I do not have any sound related problems with other browsers in this same VM.

Clearly, this is a Firefox issue. When I need sound, I have to open another browser in this same VM. Consequently, I am hoping that this functionality will return to normal in FF when Mozilla fixes the issue with
remote connections. Thanks.


(Caitlin Neiman) #2

Hi @symmetry, and thanks for your report! It looks like this is related to bug 1385207 - you might want to follow the bug for updates.


#3

If you are on a Remote Desktop Connection (RDP) on Windows, audio playback will be disabled due to increased security restrictions. This is a known issue in Firefox version 56 that we are working hard to fix.

In the meantime, you can reduce the sandbox security level by following these steps:

In the address bar, type about:config and press Enter.
    The about:config "This might void your warranty!" warning page may appear. Click I accept the risk! to continue to the about:config page. 
Search for security.sandbox.content.level and set it to 2.
Restart Firefox on the remote device. 

Source: https://support.mozilla.org/en-US/kb/i-cant-play-audio-remote-desktop-connection


#4

This sound problem continues to exist on FF 57.0.4. One substantial consequence is that there is no sound available from Firefox running in Windows 10 while on a virtual machine in Hyper-V because VMs use the RDP protocol. Unfortunately, under these circumstances, I have to use a different browser whenever I want to hear sound. :frowning:


(Daniel B) #5

Follow the instructions provided in this thread about changing the sandbox security level. Just tried it on FF 59.0.1 and it does restore audio on RDP.
This is annoying, but at least it works.