Home Monitoring with Things Gateway 0.6


(Ben Francis) #1

Hi everyone,

Today we are announcing the release of Things Gateway 0.6 which comes with new home monitoring features including support for door sensors, motion sensors and push notifications.

Other enhancements include support for push buttons and a wider range of Apple HomeKit devices, as well as general robustness improvements and better error reporting.

You can check out the blog post for more details and download the 0.6 release from our website. If you already have a Things Gateway running on a Raspberry Pi it should automatically update itself soon.

We can’t wait to see what creative things you do with all these new features. Let us know here on Discourse and on Twitter!


(button mash) #2

Congrats!

Is there a roadmap for the next things you aim to tackle?


(Ben Francis) #3

Hi @buttonmash,

We haven’t planned the 0.7 release yet, but you can see our product backlog on Waffle.

Input always welcome.

Ben


(Rei Vilo) #4

I tried to connect an Eve Degree and an Eve Room, but the sensors do not show up.

Any hint on how to connect them?


(Ben Francis) #5

@mstegeman Have you tested these devices by any chance?


(Michael Stegeman) #6

@benfrancis I’ve not tested with these specific devices, but they should (in theory) work.

@rei_vilo Are you running on the Raspberry Pi? These are both using BLE, so if you’re running on something else, a Bluetooth adapter will be required. Are you saying that they don’t show up at all on the “add things” page?

Another caveat is that they can’t already be paired with anything else.


(Rei Vilo) #7

Yes, I’m running on a Raspberry Pi. No active HomeKit concentrator is active.

There are two problems:

  • The Configure homekit-adapter page only provides the MAC addresses and generic names, like Eve, except the specific name for the Eve Energy (switch).

  • Entering the pin is then a random operation.

Using any BLE utility provides much more information, like the specific name.


(Rei Vilo) #8

Even the lescan utility provides the specific names, but with different MAC addresses!

$ sudo hcitool lescan
LE Scan ...
F5:11:86:21:73:91 Eve
F5:11:86:21:73:91 Eve Energy 47C0
DC:D7:55:23:8F:58 Eve
DC:D7:55:23:8F:58 Eve Energy 23C7
EB:D8:24:E7:A6:64 Eve
EB:D8:24:E7:A6:64 Eve Room ABA1
DC:D7:55:23:8F:58 Eve Energy 23C7
C6:D3:E9:03:4A:27 Eve
C6:D3:E9:03:4A:27 Eve Weather 2359

(Michael Stegeman) #9

@rei_vilo I discovered several issues with the HomeKit adapter this morning. I just pushed out an update. You’ll also need to update your “Web Thing” adapter to the new version, and disable Bluetooth scanning in its configuration. It turns out that the two were conflicting and causing issues.

The naming issue seems to be adapter-specific. All we get is what the noble NodeJS module gives us.


(Rei Vilo) #10

Thank you for investigating. Is the new release numbered 0.31?

How to disable scanning?


(Michael Stegeman) #11

Yes, that’s the correct version. To disable Bluetooth scanning:

  1. Navigate to Settings -> Add-ons
  2. Click Configure next to “Web Thing”
  3. Check and uncheck the box next to “bluetoothEnabled” (otherwise the form won’t recognize the change)
  4. Click Apply

(Rei Vilo) #12

Thank you for the procedure. There is some improvement. The name of the device is now shown, Eve Room in this case.

Unfortunately, the correct PIN is rejected.