Initial Setup - how am I screwing this up?


(Evan C) #1

I’m having trouble with the initial setup. I select my wireless network, enter the password, then nothing.

From the browser on my PC it just sits on the “connecting” screen indefinitely. I can tell something has happened because the mozilla SSID broadcast stops and my computer reconnects to my wifi network after about 15 seconds.

From my android I get directed to a “sign in to network” form but the form closes after I enter my network credentials.

Either scenario, I can’t move on to the subdomain form, nor get the Pi to broadcast the gateway SSID again. I flash the SD card again, get the network login, and the cycle starts again. What mistake am I making?


(Evan C) #2

Also tried to navigate to gateway.local in Chrome and Firefox without any luck. Just got browser and ISP search results.


(Michael Stegeman) #3

After doing the WiFi setup, you need to switch back to your home WiFi network (or whatever network you set the Raspberry Pi up to use), and then visit http://gateway.local in your browser to finish setup.


(Evan C) #4

This is where I think I may be screwing up. Here’s what I get when I navigate to http://gateway.local:


(Michael Stegeman) #5

It can take a minute or two for the gateway to start up after WiFi setup.

If that’s not the problem, it’s possible that mDNS is not working on your network. If you know the IP address of your gateway, you can browse directly to http://<ip-address> instead of http://gateway.local. You could also try http://gateway/ which seems to work fine on my network.


(Evan C) #6

Thanks. I gave it 40 minutes for the gateway to start up, just in case. No dice.

Direct IP address and both gateway.local and gateway still aren’t doing it. Changed my DNS servers. Could it be a firewall setting somehow?


(Tom) #7

I’m running with the pi connected via Ethernet. Is there an option to purely connect that way (for resilience and speed)?
Does the build prioritise Ethernet over Wi-fi?

Thanks.


(Ben Francis) #8

You can use Ethernet instead of or in addition to WiFi. You can do first time setup by plugging into Ethernet, loading gateway.local in your browser and then clicking “skip” at the WiFi setup screen. Or you can configure WiFi and use both.

I’m not sure whether Raspbian prioritises Ethernet or WiFi, but that’s all down to the underlying OS.