Help with installing and start up of Mozilla IoT

Sorry in advance it this has been covered but I cannot figure out why I can’t get the mozilla IoT to work for me. I’m trying to get this loaded onto a Raspberry Pi4. I’ve downloaded to my windows machine and used Raspberry Pi Imager v1.6.2 to load the software onto a 32 GB microSD drive. (it writes and verifies perfectly - I tried balenaEtcher and consistently got a verify write error). I put the drive into the Pi4 it expands resizes the root file system, reboots, and goes down a long list of text operations before ending at “Raspian GMU/Linux 10 gateway tty1, gateway login:” I find Web Things Gateway CCC4 wi-fi network and connect to that network. It then gives me listof networks to connect to which I select my wi-fi network in my home. It disconnects from the Web things gateway connects to my home network and then nothing. I’ve tried to go to or go to http://gateway.local with no results…I get the message that it times out…after that even after rebooting the raspberry I do not see the access point to log onto to start the process. Can someone please advise me on how to fix this. So far I’ve not gotten anywhere with this I’m mystified as to how the rest of you got this to work

Hi @bspindor, sorry to hear you’ve been having problems.

The problem is probably that your Windows machine doesn’t have support for mDNS configured so can’t locate your gateway via the gateway.local domain.

Once the gateway connects to your home network its IP address changes from to a dynamic IP address assigned by your router. You’ll need to find out that IP address in order to access the gateway and complete its setup.

Probably your best bet is to dig into the user interface of your router and see if you can find the IP address that was assigned to the gateway by DHCP, but failing that there are various other methods you can try documented here.