Install failed, using commands from DP Documentation

I ran the terminal commands listed at, and it ran into a number of errors, see below. I thought maybe it was a Python issue, but attempting to apt-get python3, got “python3 is already the newest version (3.6.7-1~18.04).” Thanks!

user@galliumos:~$ # Create and activate a virtualenv
user@galliumos:~$ virtualenv -p python3 $HOME/tmp/deepspeech-venv/
bash: virtualenv: command not found
user@galliumos:~$ source $HOME/tmp/deepspeech-venv/bin/activate
bash: /home/user/tmp/deepspeech-venv/bin/activate: No such file or directory
user@galliumos:~$ # Install DeepSpeech
user@galliumos:~$ pip3 install deepspeech
bash: pip3: command not found
user@galliumos:~$ # Download pre-trained English model files
user@galliumos:~$ curl -LO
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   652  100   652    0     0   2166      0 --:--:-- --:--:-- --:--:--  2173
100  180M  100  180M    0     0  10.3M      0  0:00:17  0:00:17 --:--:-- 13.1M
user@galliumos:~$ curl -LO
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   654  100   654    0     0   1672      0 --:--:-- --:--:-- --:--:--  1668^[
100  909M  100  909M    0     0  13.3M      0  0:01:08  0:01:08 --:--:-- 11.6M
user@galliumos:~$ # Download example audio files
user@galliumos:~$ curl -LO
  % Total    % Received % Xferd  Average Speed   Time    Time     Time  Current
                                 Dload  Upload   Total   Spent    Left  Speed
100   642  100   642    0     0   1969      0 --:--:-- --:--:-- --:--:--  1969
100  192k  100  192k    0     0   210k      0 --:--:-- --:--:-- --:--:-- 1425k
user@galliumos:~$ tar xvf audio-0.8.1.tar.gz
user@galliumos:~$ # Transcribe an audio file
user@galliumos:~$ deepspeech --model deepspeech-0.8.1-models.pbmm --scorer deepspeech-0.8.1-models.scorer --audio audio/2830-3980-0043.wav
bash: deepspeech: command not found
user@galliumos:~$ ^Cpre-trained English model is available for use and can be downloaded following the instructions in

If you are new to DeepSpeech don’t use latest - as stated in the docs - as the master might have breaking changes.

Start over with the 0.8.2 branch and the 0.8 model and use this schema for reporting. Unformatted output is hard to read:

So you don’t have virtualenv which we document as a dependency. Since this failed, everything else is expected to fail.

Please sudo apt install python3-virtualenv

How is it not formatted?

I ran "sudo apt-get install python3-virtualenv (not just apt), and then copy-pasted the script, and seem to have gotten the same errors. Bash is still saying virtualenv command not found, and same for pip3. Thanks!

You changed your post for the code to be formatted now. Thanks.

And read about virtual environments in Python. You can see that it is turned on if the name is shown at the beginning of every line. E.g. (virtualenv)

apt-get and apt are the same, further apt has replaced apt-get. So using just apt is fine.

Installing virtualenv with sudo python3 -m pip install virtualenv worked for me.

Well, this is your system’s, please refer to those docs. Maybe you also need the virtualenv package, but this is really out of the scope of our project here.

I ran “sudo apt-get install python3-pip,” and now pip3 has no errors. Still getting
“bash: virtualenv: command not found.”

My system doesn’t have docs per se? I’m running, not much documentation there. I’m a Windows expert, but terminal error messages aren’t something I get very far into understanding.

Looks like you are not familiar with Linux/Python. As some distros can be tricky, I would advise to try a dry run on Google Colab and then move to your local computer.

And please Google errors, this one means that you need to install virtualenv …

Then why not try to contribute to making training works on windows ?

And you have not tried to install the virtualenv package like I suggested ?

Well, I’m not really responsible for that …

Same here, any progress since then @LQuerical?

Do you care documenting whether installing virtualenv package helps ?