Nightly misuse the profile of developer edition


(Jason Liu) #1

After I updated my nightly edition to 58.0a1 (2017-10-25) (64-bit), It misuses the profile of developer edition.

My solution is to go to about:profiles and set the default profile to default.


(Mark12547) #2

That sounds somewhat like the problem I had that prompted me to open Bug 1387124 - Firefox Installer.en-US launches Nightly without asking. Whatever profile is the default profile, expect it to be corrupted: the current stub installers for Nightly, Beta, or Release launch what they just installed without asking, and the launched version then attempts to update and use the default profile. At the time I tested and wrote Bug 1387124 the profile for Nightly was incompatible with the profile for Release, so I had to recreate my Release profile.

Until that issue is resolved, I cannot in good conscience recommend Nightly without also adding cautions about using the full installer instead of the stub installer, and the difference is far from obvious for the uninitiated looking at Take a browse on the wild side, and then adding the caution to create shortcuts that specify the profiles the new installs should use.

That is why I don’t go out of my way to encourage others to use Nightly.


(Mauricio Navarro Miranda) #3

You can also use the -P parameter to instruct Nightly to use a particular profile.

For instance, this is what I do:

Firefox regular profile:

/opt/mozilla/firefox/firefox -P mauricio@firefox

Firefox Nightly nightly profile:

/opt/mozilla/nightly/firefox -P mauricio@nightly

Firefox Developer Edition developre profile:

/opt/mozilla/developer/firefox -P mauricio@developer

P.S. If you plan to run more than one instance at the same time, try adding --no-remote flag to each of them.