Privacy settings not being respected and email address always public

In email settings I can read under the email address input: “Never shown to the public”

That isn’t being respected, first thing that I noticed after I posted the topic that I signed up for posting, is that my email address is always shown, no matter if I’m logged in or not, or from what device.

Please fix this, I was never warned that my email address would actually be publicly visible, and I can’t change it.

Go to your profile then Preferences and blat away your personal name which for some bizarre reason Mozilla set to our email addresses when we create accounts. But then Mozilla are using an old version of Discourse.


It’s sad that this is still an open issue.
We reported it some months ago:

Maybe also leave a comment there to remind the Mozilla people that this is still a problem. There are even bugs open on Bugzilla and GitHub, but no one actively maintaining it. :slightly_frowning_face:

1 Like

And here too.

I flagged the OP for moderator consideration. Maybe that will kick them into action and finally sort the mess out.


Thank you @bslwannabe and @mikoMK… I can’t believe how silly this problem is and how it isn’t fixed yet.

1 Like