Show extension in toolbar

After installing the Javascript Switcher extension I chose “Remove from Toolbar” from the extension’s right-click menu in the toolbar; the icon disappeared. How can I now reverse my action and show the icon in the toolbar?

I have no Overflow Menu icon in my extension toolbar.

Right click on the toolbar and select “Customize” or open the main menu (the right most button) and select “Customize” there. This will open a tab where you can pull the button back into the toolbar.

If you want to move a button to the overflow menu, use the “Pin to overflow menu” context menu item instead, or drag it into the overflow menu when customizing.

1 Like

Thank you, freaktechnik. I did read about that too, and tried it. However, the Javascript Switcher button does not appear in that group of buttons. I also tried uninstalling and reinstalling, but that didn’t work either. I’ll contact the developer.

You also could try the “Restore Defaults” button at the bottom of the Customize tab to restore the original “factory default” toolbar layout and then let Firefox re-add the extension toolbar buttons.

I had a bunch of addon icons in the toolbar, but they all disappeared for some reason. If I customize the toolbar, none of the icons are available to drag to the toolbar (maybe it thinks they’re already there?) If I remove then re-add an extension, then the icon appears in the toolbar, but there are some extensions I’ve made extensive changes to the preferences of or have accumulated a lot of data, none of which I want to lose by removing them. I’ve tried Restore Defaults, which works, but doesn’t resolve the addon icon problem.

I can’t guarantee it, but you could toggle these two preferences that [should] retain an extension’s local/random UUID between installations and the associated storage folder (the storage folder uses the local/random UUID in its name):

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

(2) In the search box in the page, type or paste onuninstall and pause while the list is filtered

(3) Double-click the extensions.webextensions.keepStorageOnUninstall preference to switch the value from false to true

(4) Double-click the extensions.webextensions.keepUuidOnUninstall preference to switch the value from false to true

1 Like

If you have your Firefox set to delete various browsing data when closing, make sure to allow the extensions to run during private mode.

1 Like

I ended up working around the problem by just restoring the profile in question from backup. However, thanks for those preferences, they could come in handy in the future so I’ve noted them.

I don’t have it set to delete any data on close, but thanks for the suggestion!