[SOLVED] How to reclaim a domain at mozilla-iot.org?

learning

(David D.) #1

When I’ve screwed up my Raspberry Pi 3 and want to start over from scratch, how can I reclaim the domain at mozilla-iot.org? I anticipate screwing up a lot (this is, after all, experimental), and I don’t want to create a bunch of orphaned subdomains. The documentation at https://github.com/mozilla-iot/registration_server/blob/master/doc/flow.md seems to indicate that it can be done, but I don’t know how to activate that procedure.

UPDATE: The procedure described by Michael Stegeman (mstegeman) worked for me. The certificate error that appeared to interfere with my previous effort occurred only when I was behind a particular proxy firewall. When I tried the procedure on a different network, I was able to connect to my subdomain with no problems.

The lesson: If you’re behind a proxy that monitors SSL connections, make sure that it uses a certificate that can be verified by a third-party certificate authority. Proxy certificates that are created by a local certificate authority or self-signed certificates, will be detected as invalid. Later on, I will investigate the procedure for adding such certificates to the chain on the gateway before subdomains are created, but for these experiments, it’s not important now.


(Michael Stegeman) #2

After reflashing, go through the normal setup routine. If you put in the same subdomain and email address you used the first time through, you will be given an option to reclaim your subdomain. When you go that route, an email will be sent to that email address with a reclamation token, which you will paste into a box on the subsequent screen.


(David D.) #3

Thank you for your reply, Michael. I tried that, but the gateway seemed to hang after I clicked the submit (“Create”?) button, but perhaps I just have to wait longer. I’ll give it a try.

UPDATE: Well, I tried, but nothing happened.

I reflashed, connected to the gateway, connected it to my wifi network, reconnected to the gateway, entered the subdomain that I had originally created with the associated email address, and clicked “Create”. The web page said “Processing…” and stayed there. Nothing happens after that. It’s been 20 minutes. Nothing has shown up in the email, and the gateway’s web page just says “Processing…”.

I can’t access the subdomain through the web. I’m getting the error “SSL_ERROR_ACCESS_DENIED_ALERT”, so I’m assuming that’s why, and the subdomain will forever be inaccessible. I’m just going to give up on that one and create a new one.


(Michael Stegeman) #4

For future reference for other people looking at this, the issue was due to proxy/firewall issues, as noted here: [SOLVED] Certificate error when accessing mysubdomain.mozilla-iot.org


(Colleen F Berg) #5

Hi, sorry to revive this.

I’d been using my subdomain for a few months, when I began receiving a certificate-out-of-date error. I got around it by using “private” mode to access my subdomain, kind of annoying.

Well, I finally have some time to attempt fix this, so I reflashed with latest version, and now I get the SSL_ERROR_ACCESS_DENIED_ALERT error. This seems to have no override option even in “private”, so now I am stuck

I don’t know much about networking at all. I’m on my home network, (Comcast wifi modem). I think I understand what the solved answer is, but haven’t a clue as to what I need to do to access my subdomain (either by fixing certificates or ???). Thanks for any guidance.


(Michael Stegeman) #7

@colleen.f.berg After reflashing, were you able to reclaim your domain during the first time setup?


(Joel Afonso) #8

It was the same with me. I don’t have a sub domain because when I clicked create and nothing happened… I wish i could have one too but now i don’t know how to do it back…