Sonoff device recognised in standard gateway

Stranger and stranger!

I have MG 0.92/Hue Bridge/several tasmotised devices all on v6.0.7.1, and these are talking via mqtt and HA and also have Hue Emulation enabled on each tasmota device. Also in the console of the sonoff I set “setoption19 1” which makes the device discoverable on wifi.

Strangely whilst I was adding devices to my Things (z-wave and Zigbee/Hue Bridge) one of the devices showed up as a light: I am able to switch this on and off and control it from the Things screen.

I changed the type from light to switch and it operates both on and off states.

I have no idea how this happened : I installed HA / Mosquito to control all these devices because it seems that Mozilla gateway is lacking in being able to control these devices.

It’s worth noting that only one out of 4 devices have shown thus far. I have enabled the same emulations, versions and console options on all devices , but the other 3 haven’t shown.

Was I lucky ? Or is this a legit “hack” to get them into MG?

Curious.

We don’t have any official support for Sonoff devices, but if you’re able to get them working via Hue emulation, cool!

Correction: it’s Tasmota 6.7.1 , not the earlier version mentioned in the original post.