[Support] uBlock Origin


(PA) #474

After reading some of the other posts, I uninstalled uBO 1.13.10 and installed 1.13.8 and that seems to work OK


(Byzod) #476

uBlock 1.13.10 is working on my phone but the option menu is not showing in the tool menu ( the 3-dots one)

info from about:support

ublock

Description Value
Name uBlock Origin/webext-hybrid
Version 1.13.10
Enabled true
ID uBlock0@raymondhill.net

browser

Description Value
名称 Fennec
版本 54.0b6
版本 ID 20170509021705
用户代理 Mozilla/5.0 (Android 6.0.1; Mobile; rv:54.0) Gecko/54.0 Firefox/54.0
操作系统 Linux 23

buildconfig

https://hg.mozilla.org/releases/mozilla-beta/rev/798ee0e6f73eaed68e3f3968a20e9ae5c7a82718


(Ray Tomy) #477

Hi.
My ublock is not work. Since about three days before.
ublock is not block all, I can’t see “ublock orgin” on Firefox menu, and,
Addon>ublock>option(settings?) is not working.

OR at Firedox menu, “ublock origin” are displayed multiple, and when I tapped it, Firefox or ublock is recognized that “Save Page” was tapped.

Android 4 Tablet and Phone.
Firefox 55 for android(updated 26 July 2017)


#478

I cannot get Ublock Origin to save settings. It does not matter what browser, or what machine, or what antivirus. If I select I am an expert, or add a filter, it stays, for the session. If I update the 3rd party filters, they stay -as they write to the database. But nothing else does.

Right now I have to import the saved setting every time I open my browser, not ideal. Windows 10 Pro, no errors or events shown.

I also get the same error on Windows 10 Home, and Windows 7, Windows 10 Pro x64 and x86, all mainly with Firefox.

I cannot find a permissions error, as that makes the most sense. Are those values also supposed to be stored in sqlite?

Thanks in advance.


(gwarser) #479

Please read https://github.com/gorhill/uBlock/releases/tag/1.13.10


(gwarser) #480

Do you clear cookies on exit?


(Scyris) #481

Any idea how to block stuff that starts with Blob:? it seems to always get thru ublock origin so far, and I can’t figure out myself how to stop anything that starts with blob: from loading. Namely its this kiritika online ad I can’t seem to stop from showing, it doesn’t show the first time it loads but if you refesh or go back after looking at an article, it then somehow manages to show up. Go to mmorpg.com to see what I mean, refresh the page once its load and it’ll show up suddendly.


(Vas Vadum) #482

I’ve been trying to diagnose whats been causing this odd issue for the last several days now. After fiddling with a whole bunch of different things for a while, finally getting some help, eventually I found out uBlock Origin is the cause.

uBlock Origin is blocking all images on the internet that are loaded when I click them via discord. If I click a direct image URL via the discord desktop app, or discord web app, the web page in firefox loads nothing, just white nothingness. Tests shown that the image was delivered to my PC and that I received the image, but the browser was just showing me nothing. This happens to any website at all. For the sake of giving examples, this is the current image failing to load;

https://cdn.discordapp.com/attachments/201994927662432256/353052414489788416/unknown.png
The others which now load because I loaded them after disabling the entire addon,
http://i.imgur.com/tmEB1Ri.jpg
http://i.imgur.com/x1s4k2A.jpg
Actually they no longer load either, all this diagnostic stuff and reinstalling ublock from scratch seems to have broken it even worse now.

I’ve disabled all filters, I’ve “turned off” ublock, and still doesn’t work, but if I disable the addon entirely, images begin loading properly. This seems to have started happening after the firefox update to 55.0.3 - 64bit but I can’t be entirely sure. No new addons have been added, nothing else has been changed. I am unable to do any more to diagnose this issue. I know its uBlock, I just don’t know why.

EDIT:
It seems to actually be an interaction between Grease Monkey, two of the scripts my greasemonkey had enabled: KeepVid Helper and Anti-Adblock Killer | Reek.

I’ve disabled the scripts for now and things seem to be workng normally again… I’ve no idea why this sudden interaction happened but I’ll go ahead and leave my post here.


(Laozi83) #483

supprimé et recréé en anglais, excuses


(gwarser) #484

Please try disabling userscripts like “Anti-Adblock Killer | Reek” https://github.com/gorhill/uBlock/issues/2930


(5cb 1ksb7e7rrvbd) #485

ive already answered that question. copy paste:
firefox has better adblocking capabilities than google chrome bcos google makes tons of money with ads :slight_smile: nothing the extension developers can do about that switch browsers or accept ads.


#486

uBlock just updated itself to v1.14.0, which is incompatible with and gets forcefully disabled by Firefox 52.3.0 esr. I used the link to v1.13.8 from the description for transferring settings to restore function, but I have a few questions:

  • Is this accidental or deliberate? Is support for 52.3.0 getting dropped as of this update?
  • If not, where do I need to check for when a compatibility update gets released?
  • In any case, what’s the situation with the version I’m now using (https://addons.mozilla.org/firefox/downloads/file/685614/ublock_origin-1.13.8-an+fx+sm+tb.xpi)? Is it going to auto-update at any point? If not, and future versions of uBlock won’t support my browser, how practical is it to keep using this version? Will it get disabled/broken by something in the future?

#487

Using Firefox 55.0.3 and have uBlock 1.14.0 and when the extension is enabled and I press F5 on a tab with https://twitter.com/ loaded, it stalls out and page never loads. If I press the Refresh button on the navigation bar, it stalls out and never loads. If I click the X which gives a blank white page and then Refresh, the page loads. Pressing CTRL-F5 works fine. Note, just turning it off for Twitter.com does not work, I have to completely disable the extension. How can I better troubleshoot this?


(Raymond Hill) #488

You have other extensions installed? If so, first thing is to try uBO alone, with all other extensions disabled (restart Firefox to be sure).


#489

Note, I’m also talking about it here: http://forums.mozillazine.org/viewtopic.php?f=48&t=2965271&p=14764486#p14764486

So far, if I enable any of the following extensions with uBlock, it stalls out on Twitter:

  • Add Bookmark Here ² 55.0.20170705
  • Extension List Dumper 2 1.0.2
  • Add to Search Bar 2.9
  • Html Validator 0.9.7.4
  • CoLT 2.6.7
  • Context Search 0.6.4
  • Custom Buttons 0.0.5.8.9
  • Element Properties 9.1-signed
  • Extension List Dumper 2 1.0.2
  • JSONView 1.2.4
  • Places’ Tooltips 3.0.20110409.1-signed.1-signed
  • Screengrab (fix version) 0.99.11
  • Thumbnail Zoom Plus 4.2
  • User Agent Switcher 0.7.3.1-signed.1-signed

With these extensions, it is still working fine:

  • Classic Theme Restorer 1.7.0beta2
  • Classic Toolbar Buttons 1.5.8beta3
  • CookieKeeper 1.9.3.1
  • Download Status Bar 15.0.0.1
  • Easy Youtube Video Downloader Express 9.17
  • Emoji Cheatsheet for GitHub, Basecamp etc. 2.0.1
  • Extension Options Menu 2.18
  • FireGestures 1.11.1
  • Print Edit 18.3
  • RoboForm Toolbar 8.2.9.5
  • Status-4-Evar 2017.03.19.12b
  • Stylish 2.0.7
  • Tab Mix Plus 0.5.0.4
  • uBlock Origin 1.14.0

I’m sure I have more extensions that it will and will not work with. Note, with all these extensions in my 52 ESR install with uBlock 1.13.8, Twitter is fine.


#490

Hi Raymond,

In the past few weeks I’ve found that usatoday.com no longer is displayed on my phone. The page comes up completely blank. If I disable ublock, or whitelist ustoday.com, it displays correctly with ads.

It used to display correctly with the ads blocked with the default settings.

I’m running Firefox 54.0.2 on Android 6.0.1.

Thank you


(Laozi83) #491

hello,
since version 1.13.10, in the “Filter lists” tab, grouping (click on the - in front of network filter (s…) to hide unchecked filters no longer works.
the first occultation works but after consulting another tab and returning to the “Filter Lists” tab, all lists appear.
FireFox 55.0.3 32-bit FireFox uBlock Origin 1.14.4


(Daniel Rosik) #492

Firefox crashes with uBlock and “alert window logins”

Hi,

Since a couple of days I have noticed a very annoying bug. Every time I visit a page with a “alert window login” Firefox crashes (don’t know the real name of this specific login window but please see the screenshot, https://drive.google.com/open?id=0B-Yj5ivtOVuCZlVBREN0R2EwMlE) .

This applies to all types of unrelated web pages, even the admin page for my router. This behavior seems only to appear to these specific login pages. Other types of logins work OK.

I have tried disabling all my add-ons and enabling them one by one, this is only related to uBlock. I have also reinstalled uBlock with only the default settings. I have tried this on two different computers, at home and at work. All tries with the same result. I can visit my router admin page on sections that are not password protected like the status page but as soon as I click on a section that requires login Firefox crashes before I even see the login window.

I using Firefox 55.0.3 (64-bit) and uBlock Origin 1.14.4 on Windows 10 (both computers).

Can anyone please help or confirm this?

Thanks!


(5cb 1ksb7e7rrvbd) #493

most probably a filter list issue.
first update to the most recent version of firefox and ublockO.
then confirm problem persists with up-to-date filter lists.
if yes: isolate the responsible filter list by disabling and then re-enabling them one-by-one.
then report in the forum of the respective filter list developer.


#494

Thanks. It’s the EasyPrivacy filter list.