[Support] uBlock Origin


(Dreejavu) #617

Thanks for your help! I have like ~5 filters, so that shouldn’t be a problem. I also tried to reproduce the problem with a clean install of uBlock and exactly the same memory leaks happened.


(Raymond Hill) #618

Follow exactly the repro steps detailed here: https://bugzilla.mozilla.org/show_bug.cgi?id=1386177#c10.

When following exactly the steps, replace…

  • “Nightly” with whatever Firefox version you are using.
  • Steps 12-19 with whatever you are doing on Youtube which causes your memory issue.

The purpose of these steps is to highlight the memory which is reportedly “leaking”: this could allow to confirm whether uBO or something else is causing the issue (at this point there is no reason to believe there is such an issue with uBO). Following as accurately as possible these steps is important – so as to not pollute the results with noise.

Unfortunately, so far none of those who have reported such issue have been willing to report back the results of these steps – I don’t understand why. Hopefully you will be more willing to collaborate in narrowing your memory issue.


(Dreejavu) #619

Hi Raymond, many thanks for your help. I followed the steps and this is the result: https://pastebin.com/KTTP6faa I’ve also run the test with the newest version of uBlock Origin, since the problem started occuring only for the last 2 weeks or so: https://pastebin.com/05Mf68QP

The test could not reproduce the issues, the browser ran smoothly and the RAM distribution seemed to work fine. It does look like it’s not uBlock Origin’s fault then. Do you have any hint for me what could possibly cause this problem then? Again, everything works fine on my default Firefox profile after I deactivate uBlock Origin, so what could get in its way? Thanks so much for your help, in any case :slight_smile:


(Major Mike) #620

How many subscriptions do you have? You may only have a few filters of your own but you could have a lot of subscriptions. Also, check to make sure you are not getting hit with a Coin harvesting script that is not covered in the Resource Abuse list that has been maintained. You might have encountered something new that is not on there and is the reason why your memory is getting so exhausted.


(Dreejavu) #621

Thanks, appreciate your effort. I have not made any changes to the default setup. This is basically the default uBlock, only that I fiddled with filtering 3 or 4 CSS classes.

I can definitely exclude any malicious scripts, although that was a nice idea by you. The problem occurs mainly with YouTube.com and reddit.com, and I don’t really visit any other (dubious) websites. Thank you for your effort, Guardian!


(Major Mike) #622

You are welcome. Check the “default” lists that you are using, make sure you need them, they are not something that could be interfering, just to be on the safe side.

As for the malicious scripts, you are right, those large sites are fairly safe, but note that several very known and popular sites that are on the order of magnitude to the sites you mentioned got hit simply because the ad source code that was used on the site was hijacked with bad code, so being large doesn’t necessary make one immune (although certainly less likely) so to be sure, make sure you check the resources shown by uB0 and also check the logger to be sure. On a side note, addons/extensions have access to your browser traffic, so they can very well inject something by accident or on purpose as well.

I might suggest you try to disable all your extension except uB0 and then do your thing and see if it happens as well. If so, then it’s something else, but if not, then you can at least narrow down that something within your profile might be causing it, enabling one by one until you hit the same problem, then you’ll know which is causing the issue, contributing to the issue or causing some sort of incompatibility that is causing the issue. Good luck.


(JB) #623

Thank you for re-coding uBo for web ext. I don’t imagine it’s easy, because some of the APIs are limiting.
This is one of the strangest support forums I’ve been on. I guess there’s no "creating an account?"
And a continuous string of comments like a chat room? OK.

Anyway, I have suggestion about some of the UI or the per site filters symbols.

Of the 3 in Settings, under Default Behavior, Disable Cosmetic Filtering is like “one of these things is not like the others.” The other 2, block media elements larger than…, and block remote fonts - are direct statements to start Blocking Elements (or “turn on blocking” by checking this).
The 3rd one, Disable Cosmetic Filtering, STOPS filtering when selected. Exactly opposite of the other 2 (or 3). I know it says disable filtering, but over all it’s confusing.

Then under My Rules, after selecting Disable Cosmetic Filtering, it shows
"no-cosmetic-filtering: * true - which is the affirmative of allowing cosmetic elements.
The others (if selected) - no-large-media: * true, is the affirmative of blocking the elements.
Again, exactly opposite.

Where it really gets odd, is uBo’s icon drop box, with red X’s for Cosmetic elements meaning something completely different on the other 3. Two different meanings for the same symbol - side by side, isn’t done much because… it’s confusing.
The X on Cosmetic Elements means blocking is OFF. (probably avg users associate a red X with something negative - “not working or not allowed.”

On the others, a big red X over the icon means it’s turned ON. Which is opposite of what most U.S. users would think a red X meant.

Couldn’t the label & action under Settings be changed to “Block Cosmetic Elements”, or such?
Then when checked in Settings, it would show in My Rules “No Cosmetic Elements” or similar.
And in the drop box UI, Cosmetic would be just like the others, instead of users asking, “now which one has the opposite meaning if it has an X?” :):grin:

A suggestion here, but using red X’s to signify "something’s turned ON or working, is counter intuitive for most people. In most GUIs, red and / or an X or slash mark, means something is off, not working, not available.

If X’s are used there at all, I’d display them when blocking is off - on all 4 items. So there’s consistency, when users see an X (or what ever), they know it means the same for all 4.
Maybe just higher visibility icons when blocking is active (or a check mark) & X’s when they’re disabled.
On sound mixing boards, they never have half the switches or sliders going up mean it’s turning on or increasing something, while the other half of switches, it’s just the opposite.


(John Dwyer) #624

After updating to FF56.0.2 and uBlock 1.14.16, I am unable to enter replies in Microsoft’s “answers.microsoft.com” forums. I just get the little spinning wheel when I click on the “Reply” option and the reply box is grayed out. When I disable uBlock everything works properly. I tried putting “answers.microsoft.com” in uBlock’s Whitelist, but that did not help. I am also unable to display this “discourse.mozila.org” site unless I disable uBlock. I had to use another browser to enter this topic. Any suggestions?

Thanks,
JohnD


(John Dwyer) #625

Applied v1.14.18. Still not working.

JohnD


(gwarser) #626

Use Firefox 57 beta https://github.com/gorhill/uBlock/issues/2990


(Massimo B) #627

Hi, I use uBlock Origin v1.13.8 on Palemoon 27.5.1.
Right click on a image and -> Block element … creates this rule:

! 10.11.2017, 10:06:46 https://www.consorsbank.de/ev/aktie/micro-focus-intl-GB00BD8YWM01/chart
||www.consorsbank.de/content/dam/de-cb/editorial/teaser/fip/Snapshot-Header.jpg_Renditions/Snapshot-Header-2.jpeg$image

However every reload I see the image again, do the same again and get the same duplicated rule.

In the log I see it was just allowed:

10:26:29  www.consorsbank.de consorsbank.de * allow ++ image https://www.consorsbank.de/content/dam/de-cb/editorial/teaser/fip/Snapshot-Header.jpg_Renditions/Snapshot-Header-2.jpeg`

Any idea? Should that be blocked?


(Raymond Hill) #628

The logger entry you quote contains the answer: you created an allow rule, which as per documentation, is meant to override any static block filter – which is what the element picker creates. Also as per documentation, allow should be avoided in most cases unless really needed (i.e. extremely rarely), since they override static block filters:

Important: Typically, use only narrow allow dynamic filtering rules to un-break sites. As these allow rules override any static filtering, this means if you use a too broad allow dynamic filtering rule you could start to allow in ads/trackers/annoyances.


#629

Can I make a suggestion to have an option of disabling the website address of the page you were on when you created the filter, being added above the filter in “My filters”. Seems counter-intuitive for a partly privacy based addon to effectively have a partial specific web history list in your filters.


(Steven Van) #630

Hello, I wasn’t sure where to go so i’ll post here. There are a few sites thar where using uBlock hide everything until the ad blocker is disabled. This is insane, the biggest perp Ive seen so far is http://www.tomshardware.com/. Excessive in your face ads is why I started using an ad blocker in the first place.


(Major Mike) #631

Are you sure you don’t have a rogue overaggressive filter that is doing this? I just checked it out and I have uBlock with tons of filters, the site shows just fine, no ads, and everything loads. Have you looked at the logger to see what is blocked? Also, do you have the uBlock protector list? It will generally resolve the sites that detect blocker and put up a wall. Since I didn’t encounter what you described, it might be worth looking into your settings a bit.


(Steven Van) #632

Yes mine showed the first one or two times I visited and then it started Ublock is all I have installed right now


(Major Mike) #633

Having a hard time understanding what you are saying: It showed the first one or two times and then it started, so which is it? The first two times or after the first two times, you can’t have it both ways.


(Raymond Hill) #634

uBO works fine on tomshardware.com. I can’t help you however, you provide no details at all (browser, version, filter lists selected, custom filters, logger output, etc.)


(Steven Van) #635

no it does not work fine. I just did a clean install ubock is using default settings the page loaded once. and now 31 ads are blocked and the page is all but empty.


(Steven Van) #636

and one other thing not sure what you mean about “having it both ways” but I said what happened. I can no longer load Toms hardware without turning Ublock off. Im using Firefox 56.02 I don’t know what your using.