[Support] uMatrix


#112

@gorhill I experienced a regression with 1.0.1rc3 (in contrast to 1.0.0) concerning domains with umlauts, that are not supported by uMatrix anymore (Screenshot below). I also can confirm the observation by @RadioActiveLobster, that the uMatrix window (dev version) is still too narrow, once the scroll bar pops up (which hides the last section).

@ceving R. Hill told me on Twitter to switch to the dev version (1.0.1rc3 at the moment) on AMO, that solves most of the menu width problem.


(Raymond Hill) #113

It’s a Firefox issue, fixed in FF 57[1]. At this point I just do not have the time to work much on uMatrix, and what would be best is that people use the beta version of Firefox (where the issue is fixed) so that I don’t have to work on a workaround which would be useful for only one version of Firefox.


[1] https://github.com/gorhill/uBlock/issues/2950


#114

@gorhill Thank you for the link. The last comment in the thread gave the info that for FF 56 it’s necessary to enable “network.standard-url.punycode-host” in about:config to activate the fix from 57, with that being done, the domain gets displayed in the uMatrix menu again, including my old rules.

Is the scroll bar problem with 1.0.1rc3 and FF 56 also a browser issue which is fixed in FF 57, or does it occur with 57 as well, requiring some tweaking from your side? If it’s also just an issue with FF 56 it’s absolutely OK to leave it as it is, since it only blocks about half of the last column and about 5 weeks aren’t too long to wait for some “optics” - no need for me to switch to the FF beta channel.


#115

@gorhill: I ran into the issue that umatrix 1.0.0.does not run properly in FF56. Im unable to upgrade to 1.0.1b4/hybrid because i did not set rules for AMO. Could you kindly provide 1.0.1b4/hybrid as release via githut to give users with this issue a chance to upgrade without temporarily disabling umatrix?


(AppA) #116

Hi @gorhill, first of all thanks once again for your contributions and efforts in open source.

I wanted to let you know that I’ve made this bugreport about the window size because I thought it was a FF56 issue, but according to Mozilla people it’s the issue with this extension. Is this correct?


(Raymond Hill) #117

It’s an issue arising from the new Photon UI. Please use the webext version of uMatrix in the dev channel on AMO. Consider the legacy version no longer supported.


#118

Edit:
Ignore AMO, use latest from github, setting xpinstall.signatures.required to false.

I’m not sure, you’ve pointed to AMO, but on AMO there’s still this bug:
AMO Version, FF 56.0


#119

@proc
Gorhill wants you to install the latest beta version from AMO, available here:
https://addons.mozilla.org/en-US/firefox/addon/umatrix/versions/beta
You’ve installed the wrong version.


#120

Regarding the grid width issue: on Android it’s the opposite - the grid doesn’t fill the full page width and I have to zoom in to be able to hit the [right half of the] right cell. (uMatrix 1.0.1rc3 on the latest Firefox Beta)

Screenshot_2017-10-04-09-51-57-1

Maybe a touch screen friendlier mode could be used on smartphones (or everywhere?), so it wouldn’t matter where in the cell you click/tap but how many times you do. Tapping multiple times will cycle through the possible states - block, allow, noop.


#121

I’m getting thin sized window with no side scroll option when i try and look at the options in the new updated version. This error doesnt appear when I install an older version. Any ideas on how to solve this?


(Holger) #123

Same problem for FF 56.0 (64-Bit). Tried with disable/enable plugin, but no success. Quite bad, as this great plugin becomes unusable like this


(HuMuK) #124

I have cured this problem with updating to the release channel (developer) of umatrix.


#125

1.1.0 is marked as compatible with Firefox for Android (56.0a1 - *), but instead of ‘Download Now’ button there is a ‘Not available for your platform’ label on AMO. (My platform is 57.0b5)
The RCs install fine, despite not being marked as compatible with Android.

I managed to install 1.1.0 by downloading the .xpi file on desktop and opening it on Android, though.


(Raymond Hill) #126

uMatrix is not compatible with Firefox for Android, I never did any work with the UI to make it work on a small viewport.


#127

What’s the best way to enable visiting Google Analytics myself, to analyze my customer’s site data, without also enabling GA tracking of my own activities generally? When I try to visit GA directly, I get the entire page prevented from loading, which doesn’t seem to be something I can try to adjust in a granular manner. Thanks.


(Raymond Hill) #128

What’s the URL for that page?


#129

moz-extension://7a5e7a8a-4d5a-48ef-b1c6-94660bacba89/main-blocked.html?details=eyJ1cmwiOiJodHRwOi8vYW5hbHl0aWNzLmdvb2dsZS5jb20vIiwiaG4iOiJhbmFseXRpY3MuZ29vZ2xlLmNvbSIsIndoeSI6Ij8ifQ==

from trying to load http://analytics.google.com/


(Raymond Hill) #130

That is the URL. So just open uMatrix’s popup panel, and unblock analytics.google.com then force a reload (by the way, I don’t see this hostname bing blocked by any of the hosts files never mind, it is indeed blocked by one of the list).


#131

Thanks, but won’t that then unblock the site from every other site I visit too? I was thinking since it was a “first-party” site, it would just work when hit directly, without having to enable it more globally than that. (And forgive my ignorance if I’m missing something obvious.)


#132

Never mind. I forgot that the rules are site-specific by default.