The addon could not be downloaded because of a connection failure


(Rbt Taxlinked) #1

I have signin my extension and try to install using inline install but it is showing below error : the addon could not be downloaded because of a connection failure


(Niklas Gollenstede) #2

What exactly do you mean by “inline install”?

Anyway. I have errors installing the new beta versions of my freshly signed add-ons from AMO all the time. Disabling the previous installation, restarting, then installing and enabling the new version always works.


(Rbt Taxlinked) #3

Inline installation means I am giving one link to install the extension so ,on click extension will get installed.


(Rbt Taxlinked) #4

see this link also:https://developer.mozilla.org/en-US/docs/Installing_Extensions_and_Themes_From_Web_Pages


(Niklas Gollenstede) #5

You said something about downloading and renaming the file, which leads to assume you are hosting it yourself, in development probably not over https.

If you visit the DuchDuckGo homepage they offer an add-on too, but they link directly to AMO. They will have a reason to do so …


(Sylvain Giroux) #6

Can you provide us the https url where you have a link to the signed extension so we can debug it on our end?


(Rbt Taxlinked) #7

This is my site link
https://demo5kentico8.raybiztech.com/signin?returnurl=%2fu%2fconnections
, presently I have kept the link on Login page itself and please check the attachement for more info.


(Sylvain Giroux) #8

Hmmm for me it worked great! See the screenshot below.

Please go to “about:config”, switch “extensions.logging.enabled” to true, then open the console (ctrl+shift+J) and try to click back on your “Install Firefox extension”). Check the logs related to the add-on installation and reply us back with the errors you caught in the console.


(Sylvain Giroux) #9

Were you able to fix the issue on your end?

If so, can you provide some information to help future devs that would stumble on this post in the future?

Thanks!


(Caio Botafogo) #10

1509651166860 addons.xpi WARN Download of https://addons.cdn.mozilla.net/user-media/addons/10902/opendownload2-4.1.2-fx+sm.xpi?filehash=sha256%3Ac25a115a7cd81aef2880e7f9bf0dadebcf74cc1df94c8c0c34036b78ba530e02 failed: [Exception… “Certificate issuer is not built-in.” nsresult: “0x80004004 (NS_ERROR_ABORT)” location: “JS frame :: resource://gre/modules/CertUtils.jsm :: checkCert :: line 169” data: no] Stack trace: checkCert()@resource://gre/modules/CertUtils.jsm:169 < onStopRequest()@resource://gre/modules/addons/XPIInstall.jsm:2462

I am getting the same error. And this is the log.