There was an error during installation: Extension is invalid


#1

I followed the first two tutorials on mozilla’s official site on creating extensions. I’m making the third one, but is getting extension is invalid when I try to load temporary add-on in about:debugging. I’ve checked my manifest.json to make sure it’s valid, and compared my tree to the extension anatomy. Can someone take a look at my code on github and tell me what’s causing it to not install? Link is here https://github.com/drinkee/grab_extension

Below is a screenshot of my console error when trying to load temporary addon

EDIT: Fixed the error, manifest_version has to be 2…i’m retarded